Jump to content
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel forum. We are very friendly and helpful group of Dodge Ram Cummins owners. We will try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use. 

     

    Registration is free. Registering on the site will provide access to many more things like...
     

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members. Post up your used parts and vehicles.
    • Member Garage where you can proudly display your vehicles and modifications that you have done to them.
    • Download files, documents, and Quadzilla Adrenaline tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.
    • Reduced Advertisements displayed to you.

Sign in to follow this  
BlackRam2500

P 1693, and a CEL, with stutter

Recommended Posts

on occasion, I have had a CEL, and the P 1693 code. I had the ECU codes checked, and it was the crank position sensor. The CEL randomly has appeared, and nothing has happened except in 2-5 starts, the CEL goes out. This happened again two days ago. Today, CEL came on again, and on the way home from work, the engine stuttered. just a miss of maybe 2 or 3 power cycles, but ran smooth with good power otherwise. I am unaware of how to get both P done, I've tried and only get one, with the P1693 code. How is this done?Am I finally having to pay attention to the crank position sensor? Any pointers?Thanks for the input.

Share this post


Link to post
Share on other sites

I'm going to take a guess you got a 2001 Dodge Cummins... (It would help to fill out you signature with information about your truck).Your going to need to get a code reader and read the codes and find out what going on. P1693 code just means there is another code present. Since I know the 2001 tend to dump just the PCM and the P1693 code is present that means the rest are on the ECM. Then the only way to see them is a code reader... Most part stores have a code reader and they will allow you to use to read the codes. Write them down...

Share this post


Link to post
Share on other sites

Its a 2000, from what I've read, the 2001's did away with the CPS. I read the companion codes previously, and it was the CPS. I'm in the midst of replacing it to insure that it is working correctly, since it apparently wasn't at least a few times before. thanks for the sig reminder.

Share this post


Link to post
Share on other sites

we just replaced the toner ring on heavyd1980's this weekend..it was in five pieces..and two of the bolts broke off in the crank throw..the crank sensor works off of it.or maybe a short in the wire.hope this helps you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×