Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
steelestang

Voltmeter going haywire on my 01

Recommended Posts

Pcm voltage regulator went out in my truck so I put in an older dodge external v. regulator. Works great at 14.6v until you drive about 5 miles then the check gauges light comes on and voltage reads pegged past 18v. I take readings at fuse block where alternator charging wire is and it is reading 14.6v. what the hell is going on? Voltage regulator is hooked up blue wire 12v switched ignition to cigarette lighter and green is to the plug on alternator. Even put on another ground from vr to ground on battery. Anyone have any suggestions?

Share this post


Link to post
Share on other sites

Well I dont know one day I could drive over an hour without it happening then all of a sudden 18v and check guages light comes on. Could a wire be bad.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...