Jump to content

No signal, emerg flasher, or break lights


Recommended Posts

Ok electrical is not my speciality, I have running and headlights. My back ups are out too. This phenomenon happined 2 months ago, lasted a day or so. I fiddled with the tilt on steering wheel and rached under dash and wiggled some wires went away. This time did the same thing, NO change! Now When I have a 6 pin trailer hooked up, I can accuate the break control and I have trailer Breaks and break lights on truck & trailer. HMMMM sound familer to anyone, hay Rogan chime in anytime... I know some of the culprits might be, fuses, flasher/ Turn Sig relay, Multifunctional switch, Emerg flasher switch... what do I add to the list to Ck this Wknd????

- - - Updated - - -

Update.... Found blown fuses for break and turn signal lights. Tried swapping out transmission relays to fix backup lights... No backup lights. Any clues??? I looked for a fuse for them.. No find

Link to comment
Share on other sites

Ok electrical is not my speciality, I have running and headlights. My back ups are out too. This phenomenon happined 2 months ago, lasted a day or so. I fiddled with the tilt on steering wheel and rached under dash and wiggled some wires went away. This time did the same thing, NO change! Now When I have a 6 pin trailer hooked up, I can accuate the break control and I have trailer Breaks and break lights on truck & trailer. HMMMM sound familer to anyone, hay Rogan chime in anytime... I know some of the culprits might be, fuses, flasher/ Turn Sig relay, Multifunctional switch, Emerg flasher switch... what do I add to the list to Ck this Wknd????

- - - Updated - - -

Update.... Found blown fuses for break and turn signal lights. Tried swapping out transmission relays to fix backup lights... No backup lights. Any clues??? I looked for a fuse for them.. No find

Fuse #7? Driver's side inside the cab, knee level fuse access? 15 amp I believe
Link to comment
Share on other sites

Thanh you very much CT. It is 15 amp!!!

- - - Updated - - -

Update... I stand corrected its a 10A fuse. I figured out what happened to all at once LIGHTS out! I pulled a stock trailer a few days ago and have since found that plug had a few corroded TOUCHING wires in the housing. That will ruin any bodies day/ night LOL..

Link to comment
Share on other sites

×
×
  • Create New...