Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
mariner

APPS Voltage Low ?

Recommended Posts

I recently installed a new Timbo APPS and everything went fine - that was about five days ago. Truck drove well (improved on OEM) and no CEL.Today I used the truck and got a check engine light come on for the first time ever :mad:.I will check the truck wiring in the morning - too p*ssed off right now to do anything remotely serious.When I checked the codes (using my Autel Maxiscan MS300 ODB11 Code Reader), I got P0216 - Fuel injection pump timing and P0222 - Apps voltage low. The truck runs fine and sounds good - nothing unusual happening so far.Has anyone have an idea of what the P0222 would cause - fuel pump timing error due to low signal voltage?Anything I need to be concerned about regarding low voltage - short term or long term?I am just trying to get a feel for what might be the outcome of the low voltage.I need to go over the wiring with a fine tooth comb.Any suggestions would be appreciated.ThanksmarinerPS - fuel pressure fine at 13 idle, 10 cruise at 60mph and 6 at WOT. New transfer pump ordered recently.

Share this post


Link to post
Share on other sites

I checked all the wiring this morning and found nothing obvious. Checked where the wires plug into the PCM (passenger side firewall behind air filter box) and had one plug actually move slightly and then clicked ! It seems that the plug was not pushed home properly from new ?Cleared the codes and did a 60 mile trip to check. On checking codes after getting back home, found only one DTC (P0216) - the P0222 has not returned. I am hoping this code was due to the new Apps install and that nothing else is a problem.Just thought I would update on what I found. Will install the new fuel lift pump later this week.Thanksmariner

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  



×
×
  • Create New...