Jump to content
Sign in to follow this  
guesswho512

Need help with code!!!!

Recommended Posts

This is guesswho's wife... guesswhoswifey :lol:

Guesswho is at work at Code Red and has asked me to make a post for him.

This morning as he went to leave for work, all of the sudden the truck would not start. :banghead:

His Air Dog fuel pump was not kicking on either. After 10 minutes of messing with different things, he finally got it to start and the pump had finally kicked on. He continues on to work and realizes know that now the check engine light is on and deceides to go to Autozone to have the code read.

At the store they get code P1689, autozone says failed injection pump.

Guesswhos question is, does this code automatically condemn the injection pump? What are our options? Also, he wanted to know if anyone knew what the ASD relay controlled that is in the fuse box under the hood?

We are freaking out! We could use any help that you can give us!

Thanks guys!

Share this post


Link to post
Share on other sites

The ASD relay gives power to the VP44 from what I can tell. Maybe it is going out. Was thinking it has been so hot out that the chip on the VP might have finally gave out but then you said you got it running so not sure what to think. :shrug: How is your fuel pressure and all that?According to Mike's pages, that code is P1689 (M)No Communication Between ECM and Injection Pump ModuleData link circuit failure between ECM and fuel injectionpump. Low power, engine derated, or engine stops.Might just be a loose connection somewhere, how did you get it to start?

Share this post


Link to post
Share on other sites

hey all. what chaos! guesswhoswifey didn't quite get the story strait. got in the truck to leave for work(45min late). it started right up like always, ran for ~2 seconds and died. when i turned the key to start it, i could tell the AirDog was not running right(just be the sound). i immediately thought my airdog died. i crawl under the truck and the pump is still in one piece and the wires were untouched. i had guesswhoswifey crank while i looked for leaks(none). popped the hood and checked the battery terminals(okay). then i swapped the fuel pump relay with another(possibly the ASD relay,tho i thought it was the horn or wiper relay). the airdog sounded normal. after cranking to purge the air. the truck started up and gave no problems. after ~5 starts later the "check engine" light went away. the wipers and horn still work, so i am not sure it was a relay. any opinions are appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×