Jump to content
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel Site. We are very friendly and helpful group of Dodge Cummins owners. We try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use.

     

    Registration is free. Registering on the site will provide access to many more things like...
     

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members
    • Member Garage where you can display your vehicles and modifications.
    • Download Files, documents, and tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.
Sign in to follow this  
dalescarcare

98.5 24 v hard start when warm

Recommended Posts

hi having trouble with hard start when warm, long extended crank will usually start, aways starts right up on cold start, some times will crank 30 seconds when warm any help app., also has codes 1693 cant seem to get other codes, key truick does not work on 98.5, i have snapon brick, and otc scan tool. has fuel pressure gauge, lift pump seems to working ok, thanks dale, also would like to add that injection pump was replaced with cardone reman pump, about 6 months ago, but only has about 2000 miles on it,

Share this post


Link to post
Share on other sites

P1693 code means there is another code present... So your going to need to keep trying to get the other code to present itsself. As for fuel pressure what is your ilde pressure and WOT pressure?

Share this post


Link to post
Share on other sites

hi having trouble with hard start when warm, long extended crank will usually start, aways starts right up on cold start, some times will crank 30 seconds when warm any help app., also has codes 1693 cant seem to get other codes, key truick does not work on 98.5, i have snapon brick, and otc scan tool. has fuel pressure gauge, lift pump seems to working ok, thanks dale

has 18 psi at idle and 10 psi at wot

Share this post


Link to post
Share on other sites

There is a overflow valve on the vp maybe you have a bad one? there cheap and easy to replace.You may have a bad pump.I just had a bad pump.Mine was junk and it was a fresh rebuild.They sent me another but it still was a drag.I hate to bad mouth places so i wont,But i know a place i will never give my money to any more.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  



×