Jump to content
  • Announcements

    • Mopar1973Man

      Server Slowness & Strange behavior   03/15/2018

      I'm aware of the server and the site speed being weird. Might find strange server error messages and other things happening randomly. What I do know is the hard drive is hitting 100% load randomly and driving the server load up high. Then for no reason, the hard drive returns back to normal loads and server load drops. I've got the hosting company watching this and attempting to find a solution. I apologize for the performance issues... Thanks for understanding... 
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel forum. We are very friendly and helpful group of Dodge Ram Cummins owners. We will try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use. 


    Registration is free. Registering on the site will provide access to many more things like...

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members. Post up your used parts and vehicles.
    • Member Garage where you can proudly display your vehicles and modifications that you have done to them.
    • Download files, documents, and Quadzilla Adrenaline tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.

Recommended Posts

VP44 gave me fits, and took almost a full 2 hours of cranking, charging, cranking, charging, cranking, charging, tightening lines, and finally, finally after all that priming drama, it started up. Timing is dead-nuts on, starts with a twist of the key, no codes, nothing. Next up: get Wal Mart to replace the dying twin of the battery I made them replace last month; pull the bed to install Mr. FASS150, and procure a Vulcan big line kit. www.ronman.org/misc/truck1.mov www.ronman.org/misc/truck2.mov

Share this post

Link to post
Share on other sites

Thanks. Right now it looks like the bed is coming off Saturday; good thing I didn't get tickets to the Rolex 24. :cry:Any tips for FASS installation once the bed is out of the way?

Share this post

Link to post
Share on other sites

Nothing hard on install... If you pulling the bed then just route the hose and go... Just consider you mounting location of your pump where the water and debris won't beat it up.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this