Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

I just notice I have a bad leak coming from my inspection place on bell housing. I am thinking front pump torque converter seal. Any ideas ? Transmission shop says they have problems with torque converter cracking at shaft? And help would be great. Thanks

Share this post


Link to post
Share on other sites

Ummm... From my old school days with 727 Transmission on V8 it might be a seal failure but more likely a front bearing had failed. It might be time to pull it out and have a shop at least look at the front bearing... I know its cheap to replace the seal but it sucks to have it start leaking again quickly after replacing... (Been there done that!)

Share this post


Link to post
Share on other sites

Found the problem, pulled the tranny out and found the front pump bolts were all loose, tranny was rebuilt by aamco about 30,000 mile ago by previous owner.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...