Jump to content

97 Dodge Diesel in Costa Rica shuts down when hitting some bumps or potholes


Recommended Posts

Costa Rica is not known for having the best roads which is one of the reasons i chose a tough truck , the other is I am providing transportation for boats up to 35' . This truck being mechanical is a blessing here in a country where the mechanics macgyver many things and most do not have the tools. I have been keeping this girl running in the tropics but I have been struggling with a problem for the past 2 yrs . Please help me . I am having 2 problems which i believe are inter-related . 1, randomly and I have never been able to see any pattern I go to start her and when i crank it she starts right up but when i release the key she shuts down . I know this is due to the shut off valve and so to get to where I have to go I shove a screwdriver in place to hold the shutoff valve open and fire her up and she will stay running fine . I get in the cab and there are no gauges nor a/c which is hard to deal with in Costa . Sometimes in route the power will just come on to the gauges and everything will work fine . It sometimes will go for over a month without happening . 2: driving down the road and i hit a sharp bump and the engine dies , sometimes it will startup again and others i have to pull over and once again jam the screw driver in place to hold the shitoff valve open and fire it up sometimes power come back to the gauges, ac and solenoid while driving and sometimes it does not and i drive it this way till i get where I am going the pull out the screwdriver . Things I have done in search of this gremlin1 new shutoff 2 new fusible link 3 new relay for shutoff 4 cleaned and inspected the grounds i could find . I have the steering console apart because i read somewhere there may be a relay for the dash power in there but no luck yet . Any help or suggestions would be greatly appreciated

Link to comment
Share on other sites

I had a hunch that it was a relay or something that supplied power to the dash and warning lights as well as the shutoff low power . I took apart the steering column and the panel below it and found 3 relays taped together I am not sure if all 3 were stock or to do with my alarm . Anyways with it running i started tapping the relays and sure enough one of them produced the exact same symptoms when I tapped it . When it would not stay running i just tap it until the dash powers up and away it would go . I am going to try and find a new relay tomorrow and put it in and I think the problem will be solved . :hyper::hyper: I will let you know . Thank you for the reply

Link to comment
Share on other sites

×
×
  • Create New...