Jump to content

pile of codes


Recommended Posts

Hi all, new to this forum and do I have a good one. what we have here is a 2001 3500 drw 6 speed, chip is back to stock 4 inch exh and a k&n, other than that all stock. Ok here we go, I have a pile of codes and I don't always get the same ones when I clear them. 1693 0522 0117 1475 0237 0217 1295 0122 0127 these are the most common ones I get back when I ether clear them with disconnecting the batts or with a scanner or the smarty. The other thing is going on is the gages are all over the map, temp goes up to 240 and sets more chimes and things, oil gage intermittent, volt sometimes goes down when revving up and oh, the thing misses horribly. So these are the things I have tried, load tested batts, cleaned terminals, checked all the grounds under hood, pulled all terminals apart and inspected, checked for the ac bled, alt puts out 14 v and connections are good, started to get water in fuel light but I have an airdog and do not have that function but drained and checked anyway, checked all fuses, said a lot of bad hatefull things. Well with my 2 index fingers sore I hope someone out there can help. Thanks John 

Link to comment
Share on other sites

  • Administrator

From what I have heard, if the ECM goes out it will puke a bunch of codes like that. That would explain the gauge cluster freaking out too. Seems like you have checked out everything else. The one question I have, were you able to check the AC noise coming off of the alternator? If it is high, it may have taken out the ECM. These are just my thoughts. I am sure someone else will pop in too.

Link to comment
Share on other sites

  • Administrator

The only reliable source for ECM that I know of is the Dodge Dealer. Re-manufacture shops are a bit risky if you decide to try it. Make sure to get the warranty in writing and be sure you ready for hit and miss. Some have had good luck and many other have a brick or door stop that comes back in the mail.

Link to comment
Share on other sites

  • Administrator

Ok. If you want to test stand the whole thing if you have a friend with a like model truck you should be able to trade ECM's and see if the problem trades.

 

Another thing to look at is... Does the "Wait To Start" light come right on or does it delay to come on? This is sign of bad memory in the ECM and having booting issues.

Link to comment
Share on other sites

×
×
  • Create New...