Jump to content

Wastegate opens at 2500 RPM WOT


Recommended Posts

Hey guys, I have a 2004 3500 SLT single rear axle 5.9. Had an issue come up within the last week. Had my injectors and tubes and TPS sensor replaced about 6 months ago because of a starting issue. At wide open throttle 2500 RPM sounds like the wastegate dumps open and I lose all power but if you keep it floored you can see the RPMs climbing slowly. As soon as you let off the pedal and hit it softly you gain power again but right at 2500 RPMs it drops off again. Only code stored is a fan code p0483. Haven't had a chance to test the fan but it seems to be working.. I tried disconnecting the fan and driving it but it does the same thing at 2500 RPMs. Any help would be great. Thank you.

Link to comment
Share on other sites

  • Board Of Directors

Is this an early 04 or a late o4 (04.5+)?

If it is early, it should be 100% mechanical. That would lead me to believe there is a diaphragm issue.

If it is late, there could be an electrical issue causing it to open.

 

Do you have any gauges that could help diagnose the problem? Boost, rail pressure, etc.

Is this problem recent or has it been happening since you had things changed?

Link to comment
Share on other sites

It was manufactured 4 of 2004. It's an electronic waste gate actuator. started within the last week. No gauges hooked up.

Alright guys sorry for being an idiot. Don't know why I didn't take the two minutes to check it the other day but figured it out.... 

1468533670968-1364758452.jpg

Link to comment
Share on other sites

×
×
  • Create New...