Jump to content
Sign in to follow this  
afaletto

Random Bucking

Recommended Posts

Hey all, I have been fighting a random bucking problem in my truck for about a year now. It will buck in any gear and at any throttle, even at just idle. It acts like the motor just shuts down and then insantly starts back up. I have done an APPS reset several times and it always seems to fix the problem for a week or two, and then it comes back just like before. Some days it won't even do it, and then sometimes it will be almost impossible to drive for a few minutes. No codes, and I have 13 psi FP all the time and the VP is only like 2 years old. From what I have read, this is not typical APPS failure behavior, but the reset always seems to help??? Any ideas...I almost want to buy a Timbo just to check but i dont know... Thanks

Share this post


Link to post
Share on other sites

Well all my grounds that I could check looked good, so I bit the bullet and ordered a Timbo Apps. No more symptoms. Bucking, dead pedal, not starting and then starting....all gone. Easy install directions from Timbo, and the pics from Mopar1973Man brought it all together. Thanks for the help.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×