Jump to content

Recommended Posts

I’ve been chasing issues with my VP for several months now. The truck would crank and run fine until it came up to operating temperature then would break up and most of the time shut off. 
so i but the bullet and ordered another VP from DAP
installed this VP along with new batteries and a fuel pressure gauge. 
I get the pump bleed and fired up. 
Runs good so while in the shop i was gonna swap out the dash. 
Got the new dash in and fired the truck up, after 5 seconds it shut off. 
Fired it up again and the same thing. Ran for 5 seconds and shut off. 
Third time it would not refire. 
So i contacted DAP and they said send it in and they would take a look at it. 

Sure enough the PSG had gone bad. 
So they sent me a new VP and get it installed last nigh. Go to bleed the pump and could not get it to fire. 
I do now have a 1689 code. 
Is it possible that the last pump took out the computer?

I did have the computer rebuilt last year. 

Im at a loss here and I’m pretty frustrated with this girl. 
 

On a side note DAP was easy to deal with warranting the pump. 

 

Link to comment
Share on other sites

  • Board Of Directors

Hot wire the pump to see if the engine will start that way.  this will eliminate there being another bad pump, then test wires and components for voltage, continuity, and grounds.

 

  https://mopar1973man.com/cummins/articles.html/24-valve-2nd-generation_50/51_engine/59_fuel/hotwire-test-vp44-r615/?tab=comments#comment-87

Link to comment
Share on other sites

4 hours ago, IBMobile said:

Hot wire the pump to see if the engine will start that way.  this will eliminate there being another bad pump, then test wires and components for voltage, continuity, and grounds.

 

  https://mopar1973man.com/cummins/articles.html/24-valve-2nd-generation_50/51_engine/59_fuel/hotwire-test-vp44-r615/?tab=comments#comment-87

I did this test and the truck will start. 
 

A thought i had was about the anti theft system. If this complete dash is out of a different truck could that be a problem?

I did contact @Auto Computer Specialist and I’m gonna send them my ECM and PCM to have them checked out. 

Link to comment
Share on other sites

49 minutes ago, Mopar1973Man said:

So if it starts hot wired then the security function very well could be hanging up starting on the ECM. Might ask @Auto Computer Specialist if it's possible to flash that code out so it gone. The other thought would be order a new key fob and have a dealer flash the fob codes in.

I’ve got the PCM and ECM boxed up ready to ship out to them. I’ll make a note for them to do what they can for the security. 

  • Like 1
Link to comment
Share on other sites

×
×
  • Create New...

Advertisements and Ad Blockers

Mopar1973Man.Com uses the income from advertisers to pay the bills on the website. Please whitelist your ad blockers for Mopar1973Man.Com this will allow advertisements to display on our pages but allows you to still block ads on the other websites you visit. 

 

image.png

I will whitelist Mopar1973Man.Com