• Announcements

    • Mopar1973Man

      Quadzilla Tunes   06/12/2017

      QUADZILLA TUNE REPOSITORY - There is now a Quadzilla tune download area. When you submit a tune file to the download area it will automatically create a forum topic that allows discussion of your tune. So export your tune and upload it to the site. Then we all can help out in building better tunes. Check it out gang...
    • Mopar1973Man

      911 Support Group   06/22/2017

      Hey Gang, I've got the 911 support group database back up and running once again. It's listed in the 911 support category. It will allow members to list their contact information and location so other have a listed of members to call upon in the time of need. So if you wish to support other member please stop by and add your listing into the database. https://mopar1973man.com/cummins/911-support.html/contacts/

Archived

This topic is now archived and is closed to further replies.

ROAD RAGE

Hy/Boost Question

9 posts in this topic

Is there a check valve in the power steering pump to the booster line/or line it self ?????? The reason I ask is mine, (after setting awile) Starts losing fluid out the fill cap.This is the second time this has happen.Is this normal for this truck or is there a problem? I'm thinking I need to drive it more.:pray::pray:Thanks Ed............................................

Share this post


Link to post
Share on other sites

Yes the power steering fluid, It's leaking out the cap, (on the pump) I was thinking:duh: beening the booster was higher than the pump the problem was it's draining back down and over filling the pump housing after setting awile. Ed.................

Share this post


Link to post
Share on other sites

or maybe some trap air bubbles?did you just flush a fluid change or something?wonder why?:shrug:

--- Update to the previous post...

now that is a video that i would like to see..is the correct way of getting out all of the fluid so new could go back in.:thumb1:

Share this post


Link to post
Share on other sites

Na, Havent done nothing.It's did this before after sitting for awile. Now when I start it, It'll be low on power steering fluid. The truck sits in a heated garage around 60deg. It been in the same spot for a month, (not started) all of a sudden looked under the truck and it has power steering all over the floor. Checked fluid leval and its over full....... EDIT;That's why I'm thinking it's draining down/back into the power steering pump housing..........

Share this post


Link to post
Share on other sites

Na, Havent done nothing. It's did this before after sitting for awile. Now when I start it, It'll be low on power steering fluid. The truck sits in a heated garage around 60deg. It been in the same spot for a month, (not started) all of a sudden looked under the truck and it has power steering all over the floor. Checked fluid leval and its over full.......

Share this post


Link to post
Share on other sites

Check the fittings on the lines are they loose?

Share this post


Link to post
Share on other sites