Jump to content

Archived

This topic is now archived and is closed to further replies.

hawkeye213

turbo squeal

Recommended Posts

Ok last July my if you remember my tranny went out on my trip to Montana. I remember posting that about an hour before my tranny blew up we were climbing up a pretty steep hill at about 65 mph and I got like a 2 sec squeal and it sounded like it came from the turbo I pulled over and popped the hood and took a look and didn't see anything out of the ordinary and I could not make it do it again. So we just went on. An hour later the tranny blows. I just figured the noise had something to do with the tranny. OK here we are 5 months later. The other day I am driving down the road upshifting to 6th and when I hit 65 mph I get this same squeal again. Its just a short little squeal I look at my gauges everything is normal. The truck doesn't miss a beat. It doesn't sputter or cough or nothing. Last night on my way home it does it again but this time my check engine light comes on. Same thing upshifting and at 65 MPH I get the squeal. I look at my gauges and everything is fine. So I start watching my boost and try and make it happen again when I get to 65mph I get the squeal again and I am watching my boost gauge when the squeal happens my boost gauge is at 10 and then drops very quickly to like 8 and then immediately goes back to 10 after the squeal stops. It happens so fast that if your not watching the gauge when it happens you will not see it. The truck runs fine it doesn't miss a beat. I pulled the code an I got pcu 0500 and ecu 1693. So my friends what now. Your thoughts and help would be greatly appreciated.Thanks Rob PS I just went out and started my truck and the engine light is off now. Have the same codes P PCU 0500 P done P ECU 1693 P done

Share this post


Link to post
Share on other sites

I put a new rear seal in a while back. Is the P 0500 that rear speed sensor or something. Is there a list of codes here I can look at.

Share this post


Link to post
Share on other sites

Yes, the 0500 is the speed sensor. There are 3 on the truck, both front wheels and on the diff. If you have spun any of the wheels(snow, mud), it will trip the 0500. At least, this is what it did on mine.

Share this post


Link to post
Share on other sites

"Have you tried to test for BOOST LEAK ?? " No I have not. Could you tell me how to do it. I really know nothting about the turbo but I guess I am fixing to learn. Thanks Rob

Share this post


Link to post
Share on other sites

"Have you tried to test for BOOST LEAK ?? " No I have not. Could you tell me how to do it. I really know nothting about the turbo but I guess I am fixing to learn. Thanks Rob

Hey man Basically build one of these to put over turbo intake and start pusing compressed air http://www.dieselsite.com/index.asp?PageAction=VIEWPROD&ProdID=607 http://www.cumminsforum.com/forum/98-5-02-performance-parts-discussion/309016-boost-leak-tester-finally-pictures.html

Share this post


Link to post
Share on other sites



×