Jump to content
  • Announcements

    • Mopar1973Man

      Server Slowness & Strange behavior   03/15/2018

      I'm aware of the server and the site speed being weird. Might find strange server error messages and other things happening randomly. What I do know is the hard drive is hitting 100% load randomly and driving the server load up high. Then for no reason, the hard drive returns back to normal loads and server load drops. I've got the hosting company watching this and attempting to find a solution. I apologize for the performance issues... Thanks for understanding... 
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel forum. We are very friendly and helpful group of Dodge Ram Cummins owners. We will try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use. 


    Registration is free. Registering on the site will provide access to many more things like...

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members. Post up your used parts and vehicles.
    • Member Garage where you can proudly display your vehicles and modifications that you have done to them.
    • Download files, documents, and Quadzilla Adrenaline tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.

Recommended Posts

hello, newbie and first posti took my injectors out and sent them in and had them pop tested 3 came back good and the other 3 came back bad sticking nozzels,,,Can nozzels stick?i pulled the three bad ones apart just as one of your post shows and nothing was sticking so what do they mean?can this be true?

Share this post

Link to post
Share on other sites

Dirt and debris... Same thing that was wrong with my RV275 I got from CajFlynn they seen over 400K miles of roads. But they just didn't work to good for me. I took them apart and clean them up and everything works good now...

Injector Cleaning

Share this post

Link to post
Share on other sites

i took them apart and cleaned them behind the shop,so if everything moves free inside the nozzels everything is fine?

Share this post

Link to post
Share on other sites

Measure the pintles and the bore and be sure they are fitting properly... Like mine where gummed up with coked fuel and the pintle needles where about 1/2 thousandth tight. After cleaning then they fit good and smooth again.Might also look into your fuel filter and the media your using I aim for a 2-3 micron filter. Using either a Fleetguard or a Donaldson filter.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this