Jump to content

2000 cummins stalls when put in gear after warms up


Recommended Posts

i just installed a used but known to be good vp44. before doing so i never had any of the issues im about to mention. when removing old vp 44 i was rolling over alternator by the alternator pully nut to clock vp44 at 12 o clock my when my ratchet inadvertently touch the positive battery post just for a split second. after installing new pump every thing seemed fine until truck warmed up. when truck warms up and i go to put in r,d,2,or 1 it stalls if i give it some throttle it stays running. sometimes it will start right up other times it wont when it doesnt sometime the lift pump runs for 25 seconds sometimes it doesnt run at all after cracking (not sure if this is tc trying to lockup slightly or what?)ichecked for dc voltage which is about 14.5 volts when running. then i checked for ac leakage which i got around 32 volts so i unhooked all wires from alternator (the connector and big hot wire) still getting 30-32 volt of ac voltage at fuse panel underhood truck runs fine when cold goes into gear fine just not sure what this could be did i fry my pcm or ecu. could i have a air leak from vp44 swap or is my truck just junk now lol any feed back would be greatly appreciated i have worked on it for 5 day startight now and yoou guys seem like the most informed around thanks harry

Link to comment
Share on other sites

i got p0753 which is 3-4 trans soleniod circuit. Pump was taken off a running truck and they put on a hotrod pump.fuel pressure is about 12-14 psi also bleed injectors several times. also when it wont start i unhook grid heater and give a lil shot of either and she fires and runs every time but still stalls when put in gear

Link to comment
Share on other sites

I would test first by unhooking your Alternator and seeing if your truck stalls out when put into gear.If it does then i would see if there is another VP44 to swap with as it could be the issue. I have shocked my truck a few times by crossing my wrench across battery terminals, but i have never taken it from engine alternator to positive side of the battery.If your a 4WD, try putting the TC into neutral and see if it stalls out just free wheeling.

Link to comment
Share on other sites

×
×
  • Create New...