Jump to content

radio lost power i need some help


Recommended Posts

so first off i want to say that i am new to the forums. iv'e searched the web for someone who has had the same issue but so far i cant find it!

 

so i went to my camp and all was well. the next day i unloaded all the dirt bikes and quads off of my flat bed and trailer and all was well. then about 30 min later i jumped back in the truck to run to the corner store and the radio didn't work.. weird.. it never came back on either.

 

so when i got home the first thing i did was break out the multi meter. the battery power wire in the radio harness (yellow) was only coming up with .25 volts. and the ignition power wire (red) was only showing .20 volts. i checked the fuse on the drivers side of the dash in that small fuse panel and it was fine. so i stuck the multi meter in there and it was only showing .25 volts as well. i pulled every fuse on that panel and could not find a blown fuse. i also went under the hood into that larger fuse/relay panel and couldn't seem to find one for the radio.

 

my interior lights as well as everything else works fine, just not the radio. does anyone have any ideas? please help me!

Link to comment
Share on other sites

  • Administrator

Ok...

 

Power starts out on Fuse 10 in PDC which is a 50 Amp Fuse. Travels a Red wire to the ignition switch. Then from the ignition switch it turns black/white wire heading to the fuse panel in the dash. Then Fuse 8 which is 10 Amp Fuse then travels Red/White wire to the radio.

 

Then for memory... Power start at Fuse 1 in PDC which is a 50 Amp Fuse. Travels Red/Black wire to the fuse panel in the dash. Then Fuse 12 (IOD) which is a 10 Amp Fuse then travels a pink wire to the radio.

Link to comment
Share on other sites

Ok...

Power starts out on Fuse 10 in PDC which is a 50 Amp Fuse. Travels a Red wire to the ignition switch. Then from the ignition switch it turns black/white wire heading to the fuse panel in the dash. Then Fuse 8 which is 10 Amp Fuse then travels Red/White wire to the radio.

Then for memory... Power start at Fuse 1 in PDC which is a 50 Amp Fuse. Travels Red/Black wire to the fuse panel in the dash. Then Fuse 12 (IOD) which is a 10 Amp Fuse then travels a pink wire to the radio.

Thanks moparman for the detailed info! That should make it easier to narrow this problem down when I get a chance!
Link to comment
Share on other sites

×
×
  • Create New...

Advertisements and Ad Blockers

Mopar1973Man.Com uses the income from advertisers to pay the bills on the website. Please whitelist your ad blockers for Mopar1973Man.Com this will allow advertisements to display on our pages but allows you to still block ads on the other websites you visit. 

 

image.png

I will whitelist Mopar1973Man.Com