Jump to content

New Injectors Install


Recommended Posts

I changed the injectors yesterday, it was my first time doing that.  For the most part everything went well, usless you count me dropping a screw driver twice  :doh:  in between the intercoooler and radiator.  While I was in there I adjusted the valve lash and that went pretty well.  I took a picture of my cross over tubes, as this is the first time pulling them, I didn't know if this was normal.  The o rings were all still in place but  you can see how they had deformed and created a mess above their groove.  Everyone of them were like this.  The o rings themselves were all still in tact but in pretty bad shape, not sure how much longer they would have gone before I would have seen problems.  I carefully cleaned them up and installed new orings.

 

post-1984-0-55307500-1443009379_thumb.jp

 

After everything was hooked back up and began to bleed and prime the fuel system.  I cracked my fuel line, and got nothing.  I loosened the banjo on the return line at the IP and I got fuel pushing from there.  I cranked on and off for a good ten minutes and never got anything fuel at the head.  My batteries finally died so I will give it a second go this morning.  I can't see fuel leaking out of any of the connections behind the VP44, I feel those connections are good.

 

Will it usually take this long to prime after an injector change?

 

I do appreciate the wealth of knowledge on this site.  I had my wife iPad on my work bench and I was swapping between articles.

Link to comment
Share on other sites

I highly recommend you replace the carter pump. it is just a matter of time before it takes your VP with it. It it is weak it wont help your priming of the system. It would be good  at the least to get a pressure gauge  and check the pressure on the lift pump. Weak pressure from the oe lift pump or any pump for that matter is a VP killer. .

  • Like 1
Link to comment
Share on other sites

Thanks Wild&Free.  I was only opening them a quarter turn or so.  I went out and opened them up a full turn and it started withing 30 seconds or so.  It seems to be running smooth and no leaks....that I can see.  Now to let it sit and hope that it will hold prime.

Edited by Hawkez
  • Like 2
Link to comment
Share on other sites

×
×
  • Create New...

Advertisements and Ad Blockers

Mopar1973Man.Com uses the income from advertisers to pay the bills on the website. Please whitelist your ad blockers for Mopar1973Man.Com this will allow advertisements to display on our pages but allows you to still block ads on the other websites you visit. 

 

image.png

I will whitelist Mopar1973Man.Com