Jump to content

Archived

This topic is now archived and is closed to further replies.

white01

new stuff installed

Recommended Posts

white01    0
white01

well..the truck is grid heater deleted...a FBD grid heater delete was installed.....and a black power coated ats arc flow intake.....i got a block heater and a high/3cyl. box ..so no problems.i like it so far.:thumbup2::thumbup2::thumbup2::thumbup2::thumbup2::thumbup2::thumbup2::thumbup2::thumbup2:

Share this post


Link to post
Share on other sites
AH64ID    637
AH64ID

Nice, you'll have to let us know how it changes the performance.

Share this post


Link to post
Share on other sites
white01    0
white01

no..and i even thought about it while i was installing them.Posted ImageandPosted Image:thumbup2::thumbup2:

Share this post


Link to post
Share on other sites
Heavyd1980    1
Heavyd1980

nice pieces you'll have to post some pics for us all to see :drool:

Share this post


Link to post
Share on other sites
white01    0
white01

Nice, you'll have to let us know how it changes the performance.

i like it and don't have to watch the voltmeter and listen to the heater pull down the amps and such...Richard Martin(owner of Glacier Diesel Power) told me that when removing the grid heater..you take the main wire harness off and toss 'em BUT MAKE SURE THAT YOU LEAVE THE 2 LITTLE WIRES HOOKED UP TO THE SOLENOIDS BECAUSE THE ECM NEEDS TO SEE THAT IN ORDER TO NOT THROW ANY CODES!!NICE FELLA AND VERY KNOWLEADGEABLE!!so you remove the little ground wire that is on the front of grid heater..the two on the back of the grid heater and follow them down to the solenoid on the driver side down by the battery and remove the 2 THAT COME FROM THE GRID HEATER!!oh and when it is cold like it has been the last two days here in INDY..i turn the key to run..the :wts:comes on for a few seconds...go off...start the truck and NO VOLTAGE DROP..NO LIGHTS DIMMING NOTHING!!!now need a different turbo and a ats or pdi exhaust manifold...oh and still new to get them new rv275's installed!:thumbup2::thumbup2::thumbup2:

Share this post


Link to post
Share on other sites
JOHNFAK    85
JOHNFAK

no..and i even thought about it while i was installing them.Posted ImageandPosted Image:thumbup2::thumbup2:

I want one !!! nice :thumbup2:

Share this post


Link to post
Share on other sites
white01    0
white01

i run the smarty on #8..t.m.#1.....timing on #2....and the duration on#1....and the edge juice w/att. on #2(which is tow) and the low end responsiveness on highest..so that is 2x5 on you folkses drag boxes...and the new installed items are sweet...very very touchy throttle...and very responsive..even with factory turbo,exhaust manifold,and stock injectors...you'll like if ya get that stuff..the ats arc flow has 5 ports for boost,water/meth,n.o.s.,propane,and the come with 5 pipe plugs to plug 'em if you need to!!:thumbup2::thumbup2::thumbup2:

Share this post


Link to post
Share on other sites
JOHNFAK    85
JOHNFAK

i run the smarty on #8..t.m.#1.....timing on #2....and the duration on#1....and the edge juice w/att. on #2(which is tow) and the low end responsiveness on highest..so that is 2x5 on you folkses drag boxes...and the new installed items are sweet...very very touchy throttle...and very responsive..even with factory turbo,exhaust manifold,and stock injectors...you'll like if ya get that stuff..the ats arc flow has 5 ports for boost,water/meth,n.o.s.,propane,and the come with 5 pipe plugs to plug 'em if you need to!!:thumbup2::thumbup2::thumbup2:

How much for ats arc flow ?

Share this post


Link to post
Share on other sites
white01    0
white01

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

sorry truck is dirty...what else ya wanna see?

--- Update to the previous post...

i got a new replacement phone..can ya tell..i can't put the camera down!!!:lmao:

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image

--- Update to the previous post...

Posted Image:thumbup2::thumbup2::thumbup2::thumbup2:

Share this post


Link to post
Share on other sites
Wild and Free    1,104
Wild and Free

Why are you taking pics of a small red x in a box? :lmao::shrug:

Share this post


Link to post
Share on other sites
white01    0
white01

why is that doing that?i previewed every pic after submitting it and now that i am done.they are not showing up:banghead::banghead::banghead::banghead::banghead::banghead:

--- Update to the previous post...

there they are.....:hyper::thumbup2:

--- Update to the previous post...

don't see them again..what is up???????????????

--- Update to the previous post...

Posted Image

--- Update to the previous post...

need to get these 6 items in!!:thumbup2:

Share this post


Link to post
Share on other sites



×