• Announcements

    • Mopar1973Man

      Quadzilla Tunes   06/12/2017

      QUADZILLA TUNE REPOSITORY - There is now a Quadzilla tune download area. When you submit a tune file to the download area it will automatically create a forum topic that allows discussion of your tune. So export your tune and upload it to the site. Then we all can help out in building better tunes. Check it out gang...
    • Mopar1973Man

      911 Support Group   06/22/2017

      Hey Gang, I've got the 911 support group database back up and running once again. It's listed in the 911 support category. It will allow members to list their contact information and location so other have a listed of members to call upon in the time of need. So if you wish to support other member please stop by and add your listing into the database. https://mopar1973man.com/cummins/911-support.html/contacts/

Archived

This topic is now archived and is closed to further replies.

dalescarcare

transmission shift problem

5 posts in this topic

i have o2 3500 47re was working great no problems was hooking to my trailer, looked and need to move just a little, pulled up, and then it would not shift back to revears. binds up shifter, idicator came back to drive but no farther, i unhooked sheft lever at transmission, shifter went freely back to park so i could turn key off, at first i could shift low second and drive by hand at the trans. that is as far as it would go. after i shifted it a couple of times. and tryed a little harder to see if it would jump past whatever was holding, it,. now lever moves freely, anyone know what i might find when i drop the pan, is their any common shift parts that fail inside, any help app. :neutral:

Share this post


Link to post
Share on other sites

Sounds like the spool valve stuck and you stripped out a keyway or something. Time to pull the pan off and look and see. Will most likely have to pull the VB out to fix whatever the problem is. There is a small snap ring on the outer shift linkage shaft that needs to be removed for the VB to drop out.

1 person likes this

Share this post


Link to post
Share on other sites

had no shifting problems but went to change my filter and fluid and found pieces of a pretty big snap ring attached to the magnet on the bottom of the pan. any thoughts?

Share this post


Link to post
Share on other sites

had no shifting problems but went to change my filter and fluid and found pieces of a pretty big snap ring attached to the magnet on the bottom of the pan. any thoughts?

There are several big snap rings inside the tranny. Would be pretty hard to fix without doing a total tear down unless it came from the OD section then you just need to remove the t-case if its 4wd and remove the OD section which is 4 or 6 bolts can't recall right off but it will come right off the back of the tranny really simple and easy. then you can actually see the OD clutch pack and see if thats the snap ring, if thats not the one then a total tranny tear down is needed.

Share this post


Link to post
Share on other sites

DalesCarCare: Have a look at this 47RE valve body R&R: http://www.dieselperformance.com/productManual/10304,16,17,18,19_-_Valve_Body_Installation1.pdf Ignore the upgrade parts where they want to add a diode as that is for the higher hydraulic pressures that come with the BD valve body. All you want to look at is the procedure and especially that snap ring tool that is so handy. You should be able to make one with tubing, a vise and a dremel tool(or small file).

Share this post


Link to post
Share on other sites