Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

Well I was changing the fluid and filter in my wonderful stock 47re yesterday. :rolleyes: Found what looked like a 5 inch diameter snap-ring in pieces attached to the magnet in the trans pan. Had a good bit of metal shavings on the magnet also. Trans is also slipping when it shifts gears now with the fluid lever full. Worked fine until changing the fluid and filter. Anyone ever run into this? Has anyone ever used Revmax parts for their trans?

Share this post


Link to post
Share on other sites

No idea on snap ring that big ... Try and pull a 47re rebuild schematic off the Internet and see if u can find it .... As for revmax ... Yes I use them and they are good for the money ;)

Share this post


Link to post
Share on other sites

I can't give you the exact location of the snap ring, but it is from the O/D section. It is a fairly common issue that requires a press to repair and if the rest of the snap ring comes off then it can be pretty expensive. Far as slipping after the filter change, is it possible that the filter is leaking air?

Share this post


Link to post
Share on other sites

Not sure how spendy it will be to fix yours, I have a used 47re out of a 99 that was in good working condition when I pulled it out to replace it with a NV4500. Might be cheaper to replace than rebuild? Just thought that I would put that out there if you are interested.

Share this post


Link to post
Share on other sites

Well I was changing the fluid and filter in my wonderful stock 47re yesterday. :rolleyes: Found what looked like a 5 inch diameter snap-ring in pieces attached to the magnet in the trans pan. Had a good bit of metal shavings on the magnet also. Trans is also slipping when it shifts gears now with the fluid lever full. Worked fine until changing the fluid and filter. Anyone ever run into this? Has anyone ever used Revmax parts for their trans?

how many miles you got on yours? i have an 02' also with 47re in it.....every once in a while i notice it doing some gear searching between 35-40mph.....i got a temp gague on it & it seems to happen after it gets up around 160 or so.......

Share this post


Link to post
Share on other sites

Have just a little over 55,000 miles on it. I figured the fluid and filter hadn't ever been changed so thats the only reason I was changing it. I never had any problems until I changed the fluid and filter. I think I should have just kept driving it until it wouldn't move and then figure out what to do. :banghead:

--- Update to the previous post...

Not sure how spendy it will be to fix yours, I have a used 47re out of a 99 that was in good working condition when I pulled it out to replace it with a NV4500. Might be cheaper to replace than rebuild? Just thought that I would put that out there if you are interested.

Definitely interested depending on price and location considering shipping would probably be outrageous and my only vehicle that I could load a transmission in and drive wherever is the one that needs it I'm kinda limited.

Share this post


Link to post
Share on other sites

Definitely interested depending on price and location considering shipping would probably be outrageous and my only vehicle that I could load a transmission in and drive wherever is the one that needs it I'm kinda limited.

Share this post


Link to post
Share on other sites
Definitely interested depending on price and location considering shipping would probably be outrageous and my only vehicle that I could load a transmission in and drive wherever is the one that needs it I'm kinda limited.

Not looking to get a lot out of it, it is just sitting around not doing anything. When I purchased my NV4500 shipping was not bad and the company delievered here and had a tommy lift tail gate. The freight was not too bad through R and L freight. It was running good before I removed it, just wanted a manual so pulled the auto out of it.

Share this post


Link to post
Share on other sites

I am thinking $250 for it, I am southwest of Twin Falls, ID. Not sure exactly how much shipping will be, but my NV4500 shipping was only about $200 shipped from the east coast.

Share this post


Link to post
Share on other sites

Consider it sold. Is there anything I will need to get for it or do to it before putting it in? Obviously fluid and filter even though I'm a little shy about changing them since my last experience. :lmao:I work at a truck garage so it can be shipped to a place that has a way to move it(forklift, whatever). Could you handle the shipping on it and give me a total? Do you happen to have a paypal account?I'm assuming it is a 4x4 transmission since your sig says you have a 4x4.

Share this post


Link to post
Share on other sites

There should be nothing that you will need. When I removed it from the truck I made sure that the torque converter remained on the transmission. Yes, it is a 4X4 transmission, so it should bolt right in. I will give R and L freight a call tomorrow to find out what shipping will cost, what zip code will it be shipped to? Yes, I do have a paypal account. I think all you need is my email address, which is 'jonathan1950@yahoo.com'. I will get back to you as to the cost of shipping as soon as I find out what it will cost. Thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...