• Announcements

    • Mopar1973Man

      Quadzilla Tunes   06/12/2017

      QUADZILLA TUNE REPOSITORY - There is now a Quadzilla tune download area. When you submit a tune file to the download area it will automatically create a forum topic that allows discussion of your tune. So export your tune and upload it to the site. Then we all can help out in building better tunes. Check it out gang...
    • Mopar1973Man

      911 Support Group   06/22/2017

      Hey Gang, I've got the 911 support group database back up and running once again. It's listed in the 911 support category. It will allow members to list their contact information and location so other have a listed of members to call upon in the time of need. So if you wish to support other member please stop by and add your listing into the database. https://mopar1973man.com/cummins/911-support.html/contacts/

Archived

This topic is now archived and is closed to further replies.

Taz

911 need help!

2 posts in this topic

Ok Gang... I've got a 1989 Jeep Wagoner With a alternator problem or charging issue. Anyone got information on aiding on diagnostics it would be helpful... Static battery voltage is 12.5V and running is 12.2V... Kind of dark and hard to see the alternator on the bottom of the engine.

Share this post


Link to post
Share on other sites

Well I've been down there to test the output but there seem to be problems with the trigger lead on the alternator. There is no voltage at the trigger... It a delco remy alternator...

Share this post


Link to post
Share on other sites