Jump to content

Like a dead pedal but rolling coal?


Recommended Posts

So hear it is the best i can figure. I went out camping on 7-2 half way to our destination the truck started rolling coal like no tomorrow. I could fog out 4 lanes of traffic on a dangerous 6% grade, but if I could get on top of the RPM's it was fine. 1600 RPM's or better i made sure the overdrive was off, my T/C lock up switch was off. If I would just apply a very little amount of throttle and i mean less than 1/4" of movement it would start to haze then just roll black. All of the issues seamed to be with me hooked up to the trailer that weights in at 7600/lb. So I limped it home on 7-11. Then took the truck out for a drive well the issue is still there. Took it out to a buddies shop with the Snap-on Modis and found

Engine codes -

P0230 - Transfer pump out of range (AirDog 150)

P0602 - ECM fueling calibration error :think: not sure if i like this one...

P1693 - companion module error

 

Trans codes -

P0743 - Torque Converter Clutch Solenoid Circuit :think:

P1765 -Gov Press Not Equal to Target @ not15-20 PSI :think:

 

Cleared the codes to see what came back and it hasn't run right since. I have the 100hp sticks out and at the shop for a pop test and spray pattern check now but the P0602 and the trans code are puzzling me. If I'm missing something let me know or if i need more info I can do my best to get it. Thanks for the help everyone.

Link to comment
Share on other sites

  • Administrator

I know you don't have a Smarty so that tells me to test your alternator for AC noise. Also you might try to have the ECM reflashed to reset the fuel table. You might read over the diagnostics as well.

 

http://articles.mopar1973man.com/2nd-generation-24v-dodge-cummins/59-obdii-error-codes

Link to comment
Share on other sites

Every once in a great while I will get the 0602 code as well but it has never given me any driveability issues. I clear it and it goes away. Out of the 7 years of running a smarty I believe I have seen the code 3 times and one was when I changed my fuel filters and was priming the system.

Link to comment
Share on other sites

Every once in a great while I will get the 0602 code as well but it has never given me any driveability issues. I clear it and it goes away. Out of the 7 years of running a smarty I believe I have seen the code 3 times and one was when I changed my fuel filters and was priming the system.

So I went looking into this a little further and it seems that the Smarty is what sets this P0602 code. It's on there website and the tech I talked to said its a common problem.

 

I wonder if your lock up switch could have tripped the trans code? Mine never has but it is a thought....Did all these codes show up at once?

I thought this too so I just took the thing out completely and yeah this was an all of a sudden thing with all the codes and the issue.

 

Stacked tuner issue?

I thought about this also so I uninstalled the smarty and pulled the wire tap and can bus on the comp but it was still an issue.

 

with all of this I had an extra valve body in the garage so today I pulled my valve boy out of my trans and swapped them and the issue is gone at the moment. I'm assuming I have a bad T/C and Overdrive solenoids :think:  Maybe the governor pressure solenoid is stuck?

Link to comment
Share on other sites

×
×
  • Create New...

Advertisements and Ad Blockers

Mopar1973Man.Com uses the income from advertisers to pay the bills on the website. Please whitelist your ad blockers for Mopar1973Man.Com this will allow advertisements to display on our pages but allows you to still block ads on the other websites you visit. 

 

image.png

I will whitelist Mopar1973Man.Com