Jump to content

903Dodge

Member
  • Content Count

    122
  • Joined

  • Last visited

Community Reputation

7 Unskilled

Personal Information

  • Location
    Tyler, TX

Recent Profile Visitors

307 profile views
  1. 903Dodge

    903Dodge

  2. 903Dodge

    Boost Pressure High

    Had had a similar issue with a diablo power puck. But it would just throw a p0121 code. Turned out the puck was toast.
  3. 903Dodge

    Boost Pressure High

    Just an update. I have been driving my truck without issue for the last couple of days. I have sent my quad back to be checked out.
  4. 903Dodge

    Boost Pressure High

    Reset codes drove to a job this morning and nothing. I just unhooked the quad and will drive it a couple of days and see if the code come back.
  5. 903Dodge

    Boost Pressure High

    Thank you Mopar1973Man Now the truck threw a P0236 and a P0121. Was going to send the quad back tomorrow but now that is has thrown these codes I am not sure if it is the quad. Map sensor and apps?
  6. 903Dodge

    Boost Pressure High

    It has been a couple of months since I have.
  7. 903Dodge

    Boost Pressure High

    I had the defueling turned off for boost pressure. I will check the harness.
  8. 903Dodge

    Boost Pressure High

    I guess the easiest would be to check the quad harness first for resistance? Also my adrenaline should have let me choose a power level because I was past my warmup temperature. right?
  9. 903Dodge

    Boost Pressure High

    Well it started doing it again intermediately. The only way I can get the truck to move is the take the boost defueling off or sometime when I shut the truck down and start it again it goes away. I will unhook the Adrenaline and drive then report back.
  10. 903Dodge

    Boost Pressure High

    Did see that my wiretap wire had come out and was laying against the injection pump. Reconnected that and everything else looked good.
  11. 903Dodge

    Boost Pressure High

    No CEL. Stopped to to get fuel and it’s fine now. Leads me to believe a loose connection.
  12. 903Dodge

    Boost Pressure High

    I am on the road today haven’t had a chance to stop and check but my quad is showing 48psi at idle and the quad stays in power level 0 Beside a wire could my MAP sensor be dead? When I get home I will look under the hood.
  13. I had a power puck and it made the truck run weird sometime like a switch was going on and off It would also throw a Apps low voltage code. Took it off and all my issue I was having disappeared. When I opened up the puck the board was corroded and had water in it.
  14. 903Dodge

    Chipped Pinion

    I only pull the occasional stump out. I pull 7k worth of trailer and equipment half the year.
  15. 903Dodge

    Chipped Pinion

    Here are the pictures.
×