Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
Wild and Free

Cruise control intermittantly cancels itself

Recommended Posts

Just got home from a 3700 mile vacation with my 05 and It has an annoying issue with the cruise control that I have never noticed before.It will out of the blue just kick out. no rhyme or reason. sometimes it will go almost an entire day and only do it once and the next day it will kick out evey 10 miles and then just come out of it. It doesn't turn off or loose memory it just cancels like i stepped on the brake. if I hit resume its back to normal. Brake pedal is up all the way and the p-brake pedal is up also as I checked that the first time it happened. It is so extremelly intermittANT that it would be a hard one to figure out I think. Road conditions and temp did not seem to be a factor. Anyone ever run into this issue?

Share this post


Link to post
Share on other sites

Smarty Jr. maybe??? I've got the Smarty Revo, but have never experienced what you have. Dunno??!!!

Share this post


Link to post
Share on other sites

I have never had that issue... Since the CC is all ECM controlled and actuated on the 05 I would start with what normally cancels it.. bad brake switch or faulty cancel button would be where I would start.

  • Like 1

Share this post


Link to post
Share on other sites

I have never had that issue... Since the CC is all ECM controlled and actuated on the 05 I would start with what normally cancels it.. bad brake switch or faulty cancel button would be where I would start.

Makes sense to me!!!:smart::thumbup2:

Share this post


Link to post
Share on other sites

Nope I bet you will find your main wiring harness behind the knee bolster is shorting out. Remove the knee bolster then remove the harness on the steering column and look for this. Note this is on the Ing. switch

Posted Image

The issue is if you use your tilt wheel a lot the 12 AWG wire connectors start to become lose and start arcing out causing an interment connection. Mine would cut the blower motor out.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks, I will definately check it out some day. Hasn't happened in a while. But I do use the tilt a lot and was wondering about that.

Share this post


Link to post
Share on other sites

If you do find it is the harness there is a kit out to repair it, you get a new connector all the wires about three feet long, heat shrink and splice connectors. You will most likely need a new ignition switch also. Good luck, it took the dealer 4 hours to do mine and after pissing and moaning :ahhh::cry: I got Chrysler to cover the whole cost. :hyper: Don

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Donation Goals

    Mopar1973Man Medical Bills

    If you want to donate to Michael Nelson medical bills. Any fund donated here will be directed toward the medical bills and getting them paid. 


    30%
    $150.00 of $500.00 Donate Now


×
×
  • Create New...