Jump to content

Lift pump not firing before start and after key bump


Recommended Posts

Hey guys my rigs been acting weird electrically lately it sat for 9 months while I was saving for a new turbo setup. 

Now that its up and running im having several what I suspect are electrical issues here are what I think may be the symptoms of my ecu going bad( rough idle at peak high idle rpm, lift pump not cycling when I turn the key on or bump it) I do have fuel pressure while the truck runs It takes longer to start now that I dont have pressure before start up.

 

I've read similar threads but saw no resolutions

 

The other issue im having is my od, it stopped going into overdrive by itself (lock up switch did the trick for a few months) now even in lock up it wont fully lock up tach only drops 1-200 rpms. I suspect a bad apps because of an intermintent dead pedal. 

Link to comment
Share on other sites

Need info off your truck, any codes present, did you charge batteries before starting the truck after sitting that long. At first glance my suspicion is batteries were low, you fired it up and let alternator do the charging along with grids cycling. This is just a suspicion and just a wild guess, you've burned up one or more diodes in alternator sending AC ripple and might of damaged your ECM.  Is your wait to start light comes on right away with key on.

Link to comment
Share on other sites

No no I found a good used ecu for 100. This alternator is a year old still looks new ( considering it sat for 9 of those 12 months). Now that I think about it the truck started acting weird after I replaced the altertnator last go around ( reman from oriellys) I'll bring the alternator in and see if they'll warranty it out and have the new one tested before I leave.

Link to comment
Share on other sites

  • Administrator
4 minutes ago, shanechrystall said:

No no I found a good used ecu for 100

 

Make sure it's exactly the same there is over 52 different versions of ECM per year!

 

5 minutes ago, shanechrystall said:

This alternator is a year old

 

My last alternator only lasted 4 months. That doesn't mean anything now test the alternator for AC noise levels.

Link to comment
Share on other sites

  • Administrator

I've found that most part stores can actual test for ac noise to some degrade or another. Like my last time was at a AutoZone and the clerk had a simple hand held device just clips on the battery tested the system while idling. The tool failed the alternator but never gave a voltage measurement. Now at NAPA's they have a test stand that will repair full load AC voltage typically around 1.00 to 1.20 AC volt range for good alternator under full load. Another alternator shop in Ontario the gent has a very expensive hand held tool that does battery test and alternator testing on the vehicle. Just depends on how much money the store manager/owner is willing to invest on tools for the public.

Link to comment
Share on other sites

  • 2 weeks later...

Got the ecu off of a 2wd. Gave 350 for it, didn't fix my initial issue. But it did solve most of my dead pedal issues that I thought a new apps would...throwing a new apps and radiator on today might as well thouroughly go through lift pump wiring even though its operating fine while truck is running. If I dont have any luck today im gonna take it in to a shop and get bent over L O L

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...