Jump to content

Archived

This topic is now archived and is closed to further replies.

jncornett

horn sounding while unlockin doors..

Recommended Posts

jncornett

Like the title says, does anyone else have a problem with the horn/security system activating when you use the key fob to unlock the door? Its starting to get old lol.. Usually hitting the unlock button again will stop the horn sounding.. It happens about every 10-20 cycles of the door locks and mostly after rainy humid weather..Cant find any water getting into the truck. I know the truck has the premium central timer module because it has heated seats.. Can the central timer module be reflashed or does it have to be replaced? Also im supposed to be able to unlock the door with the key; turn it in the unlock direction twice and disable the secure keyless entry.. I have tried it on both doors and as soon as the door opens the alarm sounds and the truck will only run for 5 seconds or so and dies due to security protcol.. I was told by another owner of a 01 that he had to unlock the truck from the passenger side to avoid theft protection when he locks his door cause he bought the truck with both fobs mia... not the case for me. im trying to get this figured out mainly because if i lose my keys and retrieve the spare i found under the truck and the fob isnt in the cab im hosed lol TIA

Share this post


Link to post
Share on other sites
AH64ID

Is this an OEM security system? If so take a peek in your owners manual. I know on my 05 the manual told me how to disable it.

Share this post


Link to post
Share on other sites
jncornett

Thanks ill go get the owners manual and see what i can find.. Its the last electrical gremlin i have to get out of the truck..I like the idea of disableing the truck if its broken into but I hate that it sounds the horn on unlock so often as if im breaking in..

Share this post


Link to post
Share on other sites
white01

Thanks ill go get the owners manual and see what i can find.. Its the last electrical gremlin i have to get out of the truck.. I like the idea of disableing the truck if its broken into but I hate that it sounds the horn on unlock so often as if im breaking in..

i would not like that myself.looking at your sig...how does your truck run with that d-tech and stix?

Share this post


Link to post
Share on other sites
jncornett

i would not like that myself.looking at your sig...how does your truck run with that d-tech and stix?

Not to bad :drool:.... If the tranny wouldnt slip in 2nd ha ha and when the converter locks it will slip also if you press more than half throttle at about 16-1700 rpm.. well at about any rpm now lol but the goerend unit should be here by the end of the month or shortly after.. The one and only time that i beat on it after the sticks and turbo(prolly when the converter gave me the finger)from a stop at about 2/3 throttle i saw 36lbs of boost and was running 70 very quick as in crossing the bridge getting off the 4 lane from the off ramp to the of ramp west side to east side... The exhaust temps are about 100 degrees hotter than with the hy and tst j hook & boost at 70 mph is now 5psi not 15psi.. not crazy about the amout of haze and smoke i have now when the converter locks up under 45 mph.. Was hoping for a little better fuel milage with the injectors and turbo but none seen at this time still holding steady at 14.7 hand calculated, maybe after the tranny when its putting more tq to the ground that will get better .. hoping for 18 will be happy with anything better though..wondering if an edge unit will help mpg any or not previous owner had an ez and swore he got 18 city and 21 hwy... thats what the over head says now but its off..

Share this post


Link to post
Share on other sites
FlatTwin

Am having exactly the same thing happen. No rhyme or reason to it, it happens if the alarm is set or not, and does not happen every time, but on a random basis.Also does anyone know how to program the key fob to the alarm system? I bought an extra key fob/alarm control off of Ebay and they provided instructions and all it did was mess up the one good one that I have. Now the entire thing needs to be programed again (twice!) for the system to work. The original one still works but am guessing that its not right and that the alarm is not getting set.

Share this post


Link to post
Share on other sites
jncornett

Im not sure why it does it, but i think its a problem with the central timer module.. as far as reprograming the fob im not sure on that some say it can be done and others say dealer....hopefully some one with the answer will chime in.

Share this post


Link to post
Share on other sites
balsip

The reason your alarm is going off is that there is an intermittent switch contact on your drivers side "Cylinder Lock Switch". That switch is the means that the security system knows that the rightful owner of the truck is using his key to enter the truck so the alarm does not activate. If the key is not seen and the door switch looks open then the security system thinks that there is a B&E. Look at wiring diagram 8W-39-4 in the 2001 FSM in the download section. I would take the interior panel off the door and look at it and see if it is rusty or greasy. Perhaps some cleanup or contact cleaner will help. Just as a side note the computer only arms the system either via the armrest lock switch or the remote module. If you use the manual lock button the computer has no digital input on this switch and can not arm. I believe the lock tumbler will arm the system but I would have to check FSM.

Share this post


Link to post
Share on other sites
jncornett

The reason your alarm is going off is that there is an intermittent switch contact on your drivers side "Cylinder Lock Switch". That switch is the means that the security system knows that the rightful owner of the truck is using his key to enter the truck so the alarm does not activate. If the key is not seen and the door switch looks open then the security system thinks that there is a B&E. Look at wiring diagram 8W-39-4 in the 2001 FSM in the download section. I would take the interior panel off the door and look at it and see if it is rusty or greasy. Perhaps some cleanup or contact cleaner will help. Just as a side note the computer only arms the system either via the armrest lock switch or the remote module. If you use the manual lock button the computer has no digital input on this switch and can not arm. I believe the lock tumbler will arm the system but I would have to check FSM.

Thanks man ill take the door apart and check... It needs to be pulled apart any how the darn thing is not completely unlocking with 1 press of the fob...In the last week first thing in the morning i have to hit the button 2-3 times to get the drivers door opened.. I see the lock stem move but it doesnt raise up to the unlock position on the first try...

Share this post


Link to post
Share on other sites



×