Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

So I bought a 2nd gen, had high miles on it and could tell had been sitting.  Upon buying I started having troubles, after driving it home 6 hours away I started trying to get it back to 100%.   Narrowed down the first job to being bad injection pump, so I bought a new one and replaced it.   Seemed to have fixed the issue and was running good, the truck doesn’t get driven daily it’s my farm truck, I started driving it a lot in the last month and when driving the truck is fueling really weird.

 

#1.  It does have hard start after sitting over night.  After that starts fine all day. 
#2.  When driving and maintaining speed say 1700 rpm you hear the turbo and feel the truck speed up itself and slow right back down.

#3.  It does it more “aggressively” when engine is first started and I start going somewhere seems to get better as I drive.  
#4. I noticed what appears to be diesel dripping around back of engine, I’ve checked the banjo bolt and T fitting doesn’t seem to be saturated at all and all seem right.

 

Im getting directed to new injectors and crossover tubes the truck is a 2001 HO 6speed with 270k showing on it.  Was completely stock when I got it except raptor lift pump and a welding bed on it.  I have searched and can’t find any thread similar, most describe a miss or surge and mine speeds itself up and slows back down.  Any advice would be appreciated. 

Link to post
Share on other sites
  • Board Of Directors

#1 and #4 is  the fuel draining off.  I'd still start with replacing the sealing washers for the return line at the back of the head even though it shows good.  Next put some new injectors in it.  The truck most likely has some old injectors that are worn out.  Try some RV275 injectors, they a mild up grade with new o-rings and washer when installing them.

Link to post
Share on other sites

That was the direction I was leaning towards in my next step the washers for the drain off.   The fueling was my bigger concern wasn’t sure if that sounded anything like an injector issue or not.   I guess it wouldn’t hurt to go ahead and do them.   $1000 injectors and tubes still beats the crap out of a $50,000 diesel haha.   Can’t believe how much these trucks go for these days.   Appreciate the advice IB

Link to post
Share on other sites

Will definitely check out the video when I get ready to do them.    I think I’m going to order them and new tubes while I’m in it all just to ensure they’re all new.   Not knowing if anything has ever been done it’d better be safe than sorry for another couple hundred bucks.

Link to post
Share on other sites
  • 2 weeks later...

I got it all figured out guys.   Appreciate all the help.   Hard start was caused by split O-ring on #6 crossover tube.    Replaced with new tubes and 50hp injectors.   The fueling was caused by APPS sensor.  Replaced it as well and all is good 272k miles and running like a dream again. 

  • Like 2
Link to post
Share on other sites
  • Administrator

Just keep in mind after 100k to 150k miles to just change out the injectors. The o-rings are typically cooked and getting weak. Then the injectors seen all that heat for all those miles and the heat cooling cycle on the springs. Pintle moving up and down in just diesel fuel for lube.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...