Jump to content
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel Site. We are very friendly and helpful group of Dodge Cummins owners. We try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use.

     

    Registration is free. Registering on the site will provide access to many more things like...
     

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members
    • Member Garage where you can display your vehicles and modifications.
    • Download Files, documents, and tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.
Sign in to follow this  
dripley

on the road again

Recommended Posts

went home las t weekend and installed my rebuilt ecm. fingers crossed i turned the switch on and the electronics cycled like i had not seen in months:hyper:. started the engine and all was fine. stepped onthe throtle and it responded. i alsmost fell out of the truck:thumb1:. the check engine light went out and out the driveway i went. i've been driving a Dakota with rack and pinnion steering and when i hammered the gas i remembered my steering was not quite the same and held on for dear life, but i could not take my foot of the pedal. she ran great. went back home and started checking things out and my son spots fuel coming from on of the injector lines on the IP. Turned out to be one we didnot tighten when we installed the IP. Of course it was one on the back side and we had to take off half the fuel lines to get to it. That was a small price to pay to drive again. took off to maryland to work, 470 miles, ran beautifully. 20 mpg and ran like a scalded dog. I appreciate all the info i got here and will be posting on future endevors to keep Blue going another 500k. thanks again. I went to advance auto today to use ther scan tool to erase the codes still in the ecm. 2 of the codes they pulled where about problems with my " glow plugs ". we erased the codes and apparenly the glow plugs, and i cycled the switch. the only codes I have now are p done and e done.:woot: thanks to all again

Share this post


Link to post
Share on other sites

What they called your Glow Plug codes could be one of your intake air heater relays,codes P0380-P0382 By the way how many mile on your truck, mine 767K

Share this post


Link to post
Share on other sites

What they called your Glow Plug codes could be one of your intake air heater relays,codes P0380-P0382 By the way how many mile on your truck, mine 767K

I think those were the codes. I did not really care as long as they went away. 207,500 mostly trouble free miles. nothing major at all just samll stuff. 207,501 both front wheel bearings, IP going out, and the ECM died. Got paid back for the rouble free miles. all new now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  



×