Jump to content
  • Announcements

    • Me78569

      High Idle Kit Sale   09/06/2017

      Just in time for Father Winter, we are offering a %10 Discount for the first 10 High Idle switches sold until 10/1/2017.  Just use the coupon code HighIdle at checkout to get %10 off. Visit out store to see details on the High Idle Kit.       

Archived

This topic is now archived and is closed to further replies.

arcwelder

Truck shudders with performance chip

Recommended Posts

arcwelder    0
arcwelder

Hi Guys:For some time now my truck shudders with my QUAD XZT+ programmer. Someone told me this problem was fixed at the factory and that it was available in the download section of Quad's webpage which I did, but the problem is still there especially at lower speeds. Any ideas?Thanks,Arcwelder

Share this post


Link to post
Share on other sites
Mopar1973Man    3,801
Mopar1973Man

Ok... Try removing the box and the problem disappears right? Then that points to a issues with the phyiscal electronics of the box... (Most likely). Or maybe a bad connection somewhere?

Share this post


Link to post
Share on other sites
98whitelightnin    84
98whitelightnin

Have you tried different tunes? When I had one, the comp tune would do it but the 2000 tunes wouldnt.

Share this post


Link to post
Share on other sites
JOHNFAK    85
JOHNFAK

Have you tried different tunes? When I had one, the comp tune would do it but the 2000 tunes wouldnt.

yeah I had alot of problems with the XZT+ or whatever. Maybe a diff tune would help. Else and Edge EZ or Diablo powerpuck seem better hate to say it. I sent it back and got an edge and never looked back I like their higher end products though :P

Share this post


Link to post
Share on other sites
98whitelightnin    84
98whitelightnin

I had the xzt+ beta box and it was great. It did surge at lockup on the comp tune but the 2000 tunes never did, + they have high idle.

Share this post


Link to post
Share on other sites
arcwelder    0
arcwelder
Ok... Try removing the box and the problem disappears right? Then that points to a issues with the phyiscal electronics of the box... (Most likely). Or maybe a bad connection somewhere?

Yes thats exactly right. I was told that it was a programming issue, but that it is resolvable when downloading new tunes which I have done, but the problem still exists. Perhaps I need to call Quadzilla to find out whats up.

Thanks Mike.

Arcwelder

--- Update to the previous post...

yeah I had alot of problems with the XZT+ or whatever. Maybe a diff tune would help. Else and Edge EZ or Diablo powerpuck seem better hate to say it. I sent it back and got an edge and never looked back

I was very close to purchasing the Power Puck also, but then decided on the Quadzilla. I'm not sure what tune I downloaded, but perhaps I'll try another to see if it still happens. The box works good when under load though. Its kinda strange. When I'm pulling our 29ft. travel trailer its fine, but when its just the truck it shudders.

Arcwelder

Share this post


Link to post
Share on other sites
JOHNFAK    85
JOHNFAK

Yeah call quad - they were pretty good to deal with when I had my issues to be fair. What happens when you completely take the xzt+ off - shuddering stop ?? I would 1) take it off 2) put back on and make sure connections to MAP etc are good 3) try different tunes 4) call QUAD 5) get a http://www.quadzillapower.com/products/index.cfm/p/Adrenaline-Dodge-98-02 :) Can u fill out your truck specs/year/bombs etc ?

Share this post


Link to post
Share on other sites
98whitelightnin    84
98whitelightnin

There arent any custom tunes like the adrenaline, just what quad has on there site.

Share this post


Link to post
Share on other sites
cajflynn    7
cajflynn

I have one of these things and it does the same thing. I called quad today and they told me to try a different tune. I think they have their head up their ___. I would throw it at them if I was close enough. I have tried all of the tunes. This thing shudders on every tune when towing up a hill. Besides that if you get any other tune than the 2000 you lose a lot of bottom end. That doesn't help me at all. I think these things are not made right for the 2001's. This is very common problem for the XZT.

Share this post


Link to post
Share on other sites
white01    0
white01

edge juice w/att. and the smarty is an awesome stack...especially with some injectors.

Share this post


Link to post
Share on other sites
guesswho512    2
guesswho512

what do you mean by "shutters" i am looking at a adrenaline for christmas...but don't want another problem

Share this post


Link to post
Share on other sites



×