Jump to content

Recommended Posts

I have an 01 dually,that I bought from my mother after my dad passed away last year from brain cancer. The truck had sat for about 8 months,and after I had driven it for about 4 months,the lift pump failed on the way home from work,and the truck died and I had to tow it home. I replaced the lift pump,but I still couldnt get it to crank and run, it was getting fuel to all but the #1 cylinder. I checked for trouble code but it didnt display any,because the engine light wasnt on. I bought a lift pump and replaced it. I still cant get it to crank,but I did get some codes this time,they are P-1693,P-1689 @P-0122. Is there something I did wrong or something else wrong with the truck,By the way the truck only has 53,000 miles on it,I'm stumped.

Share this post


Link to post
Share on other sites

Ok... P1689 check the fuel pump relay in the PDC, Check the fuses in the PDC as well... If that is all good the the VP44 injection pump has failed... P0122 is APPS sensor code (Accelerator Pedal Position Sensor) that has failed go give Timbo a clal for a replacement... http://mopar.mopar1973man.com/cummins/2ndgen24v/apps/apps-replacement.html

Share this post


Link to post
Share on other sites

Sorry I mis printed something,I have replaced the lift pump and the VP-44 but still no justice for a poor man,Sorry about the mis print

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×