Jump to content
Sign in to follow this  
oilburner77

apps 0121 and two stroke?

Recommended Posts

Hello all. I have a dumb question for everyone. I added 2 stroke to my fuel with powerservice also. On way home i started getting 0121 code. Drove truck a couple of days later and got dead petal 5 times on way home. Tried to shut off engine twice and just kept on running. I havent had any apps codes since i got edge installed and smaller injectors. My question is will both those additives togther affect vp44 and cause 0121 code? It just seems weird it started as soon as i added them. I have a scheid hot rod vp44 and i think they have tighter tolerences. Any info would help. Im hoping i dont have to shell 400.00 for apps sensor! thanks

Share this post


Link to post
Share on other sites

Well first, you can get an APPS for $160! It is a TIMBO APPS. Let's see if you need it first! Read this and reset your APPS: http://mopar.mopar1973man.com/cummins/2ndgen24v/apps/apps.htm Second, exactly what kind of truck do you have? Fill out your signature. Look At the "USER CP" at the top left corner. This will help us all to know what your truck has. Include everything about your drive train and any upgrades. It is a coincidence with the power service and 2 stroke causing the dead pedal. How did you come up with the code?

Share this post


Link to post
Share on other sites

it may not be your VP44. the code 0121 refers to: TPS Voltage Does Not Agree With MAP---TPS signal does not correlate to MAP sensor signal. i would try cleaning your map sensor first...http://mopar.mopar1973man.com/cummins/2ndgen24v/map-sensor/map-sensor.htm then test your APPS...http://mopar.mopar1973man.com/cummins/2ndgen24v/apps/apps.htm let us know what you find.

Share this post


Link to post
Share on other sites

Wel las for mixing additive I high suggest against that... Because the PS is a cetane booster and tend to rate poorly on the HFRR scale. Now 2 cycle oil is a natural cetane reducer and true lubricant. So basically you shooting yourself in the foot.

As for the P0121 the APPS sensor is going south for sure. You can try the APPS reset and clear the codes but if the code returns the APPS should be replaced.

TPS Voltage Does Not Agree With MAP---TPS signal does not correlate to MAP sensor signal.

i would try cleaning your map sensor first...http://mopar.mopar1973man.com/cummins/2ndgen24v/map-sensor/map-sensor.htm

Ummm... You might check the error code book. The other code is a TPS (Gasser) :whistle:

http://mopar.mopar1973man.com/cummins/2ndgen24v/obd2-error-codes/error-codes.pdf

Accelerator Position Sensor (APPS) Signal Voltage Too Low APPS voltage input below the minimum acceptable voltage.

Share this post


Link to post
Share on other sites

I would have commented sooner but my computer died. Apps was bad. I got a timbo apps and install was quick and easy. No more problems and it seems to be running much better. Thanks for all the info guys!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×