Jump to content
  • Welcome Guest To Mopar1973Man.Com

    We are a Dodge Ram Cummins Turbo Diesel forum. We are very friendly and helpful group of Dodge Ram Cummins owners. We will try to keep your truck running the best we can and provide information for diagnostics, repairs and even guide you on the best replacement parts to use. 

     

    Registration is free. Registering on the site will provide access to many more things like...
     

    • Contribute to the Forum being able to ask questions and get support for your Dodge Ram Cummins.
    • Contribute to Article Database adding your ideas and suggestions.
    • Classified Ads posted by the members. Post up your used parts and vehicles.
    • Member Garage where you can proudly display your vehicles and modifications that you have done to them.
    • Download files, documents, and Quadzilla Adrenaline tunes for your truck.
    • 911 Support Network. We've got a group of members will to aid you if your truck breaks down on the road.
    • Reduced Advertisements displayed to you.

Sign in to follow this  
jlwelding

Windsheild Wipers

Recommended Posts

In the 9.5 years I've had my truck, that has happened to me about 4-5 times. Just happens out of the clear blue with no reason that I can find. I dunno either.:shrug::duh:

Share this post


Link to post
Share on other sites

Delay wipers on? Lose electrical connection? Wiper motor wore out?

No on all accounts for mine. One occasion sticks in my mind though…………………….there's a good section of road near me to "open" the truck up for a couple miles…………………anyhow; as I got to maximum speed (about 107-108mph), the wipers came on a swiped once, and shut off. The intermittent/wiper switch was in the off position.

Share this post


Link to post
Share on other sites

Every once in a while my wipers on intermediate will swipe once, stop then start again. Doesn't happen often, but been happening once in a while the last two years. Went as far as taking it to the dealers and they checked everything, but all checked fine. Confusing !

Share this post


Link to post
Share on other sites

I don't think they would be worn out. Truck only been driven in the rain twice since new. lol

Delay wipers on? Lose electrical connection? Wiper motor wore out?

Share this post


Link to post
Share on other sites

The "intermittent" part of my wipers has not worked properly on my truck since less than 1 year old. I brought it in to the stealer to get it checked then, but they said they it was a "module" which they didn't have in stock. They called a month later saying it (the module) was in stock, but I never went back. The continuous low and high work fine………..it's just the intermittent. It'll swipe once on the correct interval, then do anywhere from 2-9 continuous swipes and then go back to the "proper" interval. Can be aggravating at times, but it's livable.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×