Jump to content

DezrtRat

Unpaid Member
  • Content Count

    103
  • Joined

  • Last visited

Everything posted by DezrtRat

  1. Thanks guys, just what I was hoping to see. Are there any quirks to replacing it or is it as straight forward as it seems?
  2. It appears to be leaking from where the shaft (not pitnam arm) connects to gearbox. Since the truck has a lot of wandering, I figured I'd just replace the whole thing. Although I've found many reasonably price remanufactured ones, I've read that remanufactured boxes don't last long and some leak almost immediately. Any recommendations? This truck doesn't get driven much (4K in the last year and a half).
  3. Great, thanks. My cheap manual didn't have a schematic for this system. I'll have to break out the multimeter and shoot some wires.
  4. Sorry I haven't been here in a while but since I have no real expertise and haven't been having any problems... Anyway, Now I have a problem. By the way, I keep trying to make a donation but it keeps failing. So, my issue is that my power door locks will not lock. Not with the fob, not with the button, not when it's put into gear, nothing. However, it unlocks as advertised, i.e., with fob, when put into park, and with the passenger unlock button, not the driver's. So, I replaced both driver's and passenger's switches (located on each respective door arm rest). Has anyone had any experience
  5. Can't believe I procrastinated this long (since starting this thread) but I finally got it and between removing the old air box and installing the BHAF...oh, and strapping it down with bungie cord took all of about 5 minutes. So, I get that the heat from the turbo won't affect performance but will it melt the filter? And will the tube work its way off the filter neck without the stiffeners you guys were talking about?
  6. That's my issue. I'd like to blame the problem on the driver's switch except it's also on the passenger side. Is the passenger side a slave and the driver's the primary, meaning is the passenger side routed through the driver's side?
  7. Will do when I get home. ThanksI forgot to mention that they won't lock using either interior power switch on the driver's or passenger's doors.
  8. Since the fobs are different from the original, which I also have but doesn't work, I'd have to say they're not OE.
  9. I haven't changed anything but the truck has an alarm with different fobs from the original installed by the previous owner.
  10. So, bungie cords would be a little redneckish, huh?
  11. I know there was a thread that has a good source for the filter and hose but now that I'm looking, all I can find is the filter.
  12. My truck has had some electrical issues with door locks and windows since I got it but the latest is weird. I can unlock my doors either with the key fob or the switch and they unlock when I turn the key off..normal; however, they won't lock in any of the mentioned ways (fob, switch, or when key is turned on). Once in a while they'll work so I assume there's a loose connection somewhere. So, before I start tearing apart areas that have nothing to do with it, could someone with experience in this area steer me in the right direction. Thank
  13. I was about to mention military members. Although I'm no longer in the military, my son is and has been interested in buying a Ram diesel when he can. This is the only site I would and have recommend to anyone.Sorry for being one of the guys who hasn't been here in a while. I sometimes feel like I'm just reading since I'm definately no diesel expert (so I can't offer much advice) and my truck has been running great (knocking on wood) so I haven't needed advice.
  14. Not usually the type of person to clog up forums with politics but please get out and vote tomorrow.
  15. Just to update this issue, when I went to leave work, everything worked perfectly. I think this truck has gremlins.
  16. Tell me more. I had it rebuilt by a friend of a freind for less money (long story). Now that you mention it, it did feel like I was taking off in 2nd.
  17. No, I haven't had time to check it but it's on my list. Just don't understand why it happened so suddenly. Thanks
  18. I got into my truck this morning and the tranny seemed to feel like it was slipping when I started from a stop. This continued all the way to work, which has several stop lights (~12 miles). When I got to the last light, I shifted into low and it hooked up perfectly. It was rebuilt about 1k miles ago and sits a lot (haven't driven it in about a week).
  19. I believe all of the breakers are good and I've checked all the fuses in the fuse panel. Mine is a toy hauler and has a built-in generator. I would think it's somewhere around the generator. Now that I have a visual, I'll go out and take a look. Do they typically have any type of in-line fuses?
  20. I'm pretty sure my converter/inverter is bad. The only way to charge the batteries is to hook it to my truck or put a charger directly to the batteries. I have a 2005 Rage'n Xtra Lite and have no idea where it's located...or even what it looks like. Rage'n is out of business so there's no technical support. I'd like to find it so I can troubleshoot it. Any ideas?
  21. Just bought one for $36. Thanks for the input and I did all of the above (belt dressing followed by WD-40). The WD sure helps isolate the noise.
  22. My tensioner started sqealing like a pig. I plan to replace it but was wondering what the torque is on the bolt and if it had been over-torqued, could that make it squeal? Thanks
  23. This is correct. I have 285s and travel about 5-6 MPH faster than the speedo, according to my GPS.
×
×
  • Create New...