Jump to content
  • Welcome To Mopar1973Man.Com

    We can see you are lurking about reading the forums and article databases. We happen to be one of the most friendliest Cummins support website on the planet. Come on and register and grab a inexpensive subscription plan. With that you can unlock even more for you. Technical support either by public forum, private support ticket, and even unlock phone support by Mopar1973Man. Mopar1973Man.Com will remain FREE to read forever!

Recommended Posts

Slightly new here but have looked around, yet still cant find an answer maybe yall could help. I have a 2000 24v that will run when doing the bule chip diesel hot wire to the vp44 test but wont run with the plug. Making me think Ecm. For some background the truck was originally a v10 model converted to diesel. The only part remaining from the gas version is the physical dash and dash harness(insturment cluster was swapped as well). The truck was throwing p1693 code when i had my cheap scanner hooked to it as well as the sending unit code. When i hooked up my nice snap on one it said there was no codes? Anyone have any ideas? 

Edited by Troy717
Link to post
Share on other sites

Does the ECM know you stuck a diesel in there? Have to assume you swapped in the diesel electronics.

Has it done this since the swap?

Edited by dripley
Link to post
Share on other sites

All of the computers including the ECM, PCM, Insturment cluster, engine harness and fuse box harness came from the same truck which is whats causing my confustion. i have cleaned and attached then recleaned the grounds several times with the same result. my WTS light doesnt stay on and none of the dash lights flicker at all.

Edited by Troy717
Link to post
Share on other sites
  • Administrator

WTS is only light that is controlled directly by the ECM. If there is a WTS light issue, or wiring issue there would be P0381 code. 

 

ECM and VP44 are ground directly to the battery terminal on the passenger side. No body ground for PCM, ECM or VP44 these three are directly ground to the battery. No body grounds for these. 

 

IAT sensor and Battery temperature sensor control the WTS light for duration. These are a must for proper WTS and grid heater function.

 

All other gauge cluster functions are pulled from the CCD Network. If there is any P1698 or P1694 codes then you have a CCD network issue.

Link to post
Share on other sites
  • 2 weeks later...

To give an update. Sent the ECM out to ACS. Good guys out there got my ECM back quickly. However truck still will only run if vp is hot wired. My insight shows no dtcs. But the key trick still shows p1693. Anyone have any ideas?

Link to post
Share on other sites

Since the dash has been out you need to check the three wiring connectors that plug into the back side of the fuse block.

Squeeze your hand up above the parking brake and feel around for them, they plug into the backside of the fuse block they are extemely difficult to remove even when the dash is pulled back. The plastic latches offten get broke, I know from experience.

They could have worked loose just push on them to make sure they are seated. Did you try swapping around the fuel system relay its the one in the lower left corner of the PDC when standing by the drivers fender?

Link to post
Share on other sites
×
×
  • Create New...