Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Sign in to follow this  
scubieman

Two issues with truck 6.7

Recommended Posts

I have two issues with my truck and unsure what they are. Both just started today. 1. I am having a raddle sound coming from I believe up front. Unsure sure where. The faster I go the little louder but not much. I stop and rev the truck up No sound. So it only happens in motion. (VISUAL truck looks fine under neath. With out help unsure of how to check and how to check. 2. Check engine light is on. Unsure why, otherwise it would be fixed:doh:. But anyways the only changes in last two days have been i filled with diesel. I made sure I put right fuel in. Plus I put on only about 5-20 miles since then. Second I installed backup camera today, unsure if I hit a sensor or disconnect cable. I connected the wire needed for the backup live feed into fuse box. Unsure which one I used(my stupid) but unsure if voltage change would of done it. Any ideas for the two?

Share this post


Link to post
Share on other sites

Well check for the error codes and report back the codes... Rattle noise could be the CP3 pump. There is a long article somewhere on the internat about the CP3 gear index might land in a spot where the pump comes over the pressure point flings against the cam gear causing the rattle noise. I heard if you just re-index the gear in a new position it will resolve the issue. But if Wild & Free shows up he'll be able to verify this information a bit better...

Share this post


Link to post
Share on other sites

Well the Engine code is gone, When I grabbed the Fuel tank lid it felt lose . I did not fully check it I just turned. Anyways within about 20 minutes the Check engine light is now off. The raddle noise is still there. It gets louder with MPH not RPM. Even though I can still hear noise sitting there in park at idle. I Kinda listen under truck and it sounds like the DPF but I could not get a central location on where the noise was. The noise is much quieter now. When it was happening at first it sounded like truck was falling apart and people could easily hear from half a block to a full block away. Now you got to try to listen for it. I plan on have the dealer still check the code on this but wont be able to make it to dealer till Thursday.

Share this post


Link to post
Share on other sites

It was a battery disconnect. I got another check engine while changing the fuel filter. Not sure what it was but it was gone one I was done.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...