Jump to content

tc hunting again?


Recommended Posts

Ok I had this problem before as many cummins owners had were the tc was locking and unlocking. I researched the forums and did the apps reset and aluminum foiled the alt. wires and cleaned all connections I could find well this lasted about 6 months and 7000 miles and now its back. gonna check in to the connections in the morning and see what happens. on 1 of the forums im reading about a 1 wire alternator replacement any ideas for a easier fix? how about these noise suppresors any input if they work or not? Thanks Tom

Link to comment
Share on other sites

  • Administrator

Ok I had this problem before as many cummins owners had were the tc was locking and unlocking. I researched the forums and did the apps reset and aluminum foiled the alt. wires and cleaned all connections I could find well this lasted about 6 months and 7000 miles and now its back. gonna check in to the connections in the morning and see what happens. on 1 of the forums im reading about a 1 wire alternator replacement any ideas for a easier fix? how about these noise suppresors any input if they work or not? Thanks Tom

That tells me the alternator most likely has bad diodes when you cover the lead with tinfoil (bandaid) you proved without a doubt your alternator is creating said AC noise.

http-~~-//youtu.be/UveGtGuswBw

  • Like 1
Link to comment
Share on other sites

I took mine to the dealer and they couldn't find a problem to fix but I still had the hunt. They did say that one of my batteries was a little low compared to the other one.We charged it up and used if for another 6 months and I still had the hunt come back. Cleaned all the electrical connections and tigthen the grounds but I still had the hunt.So I went out and bought two new batteries and have been hunt free for one year already.:thumb1:

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

Ok Mike, what do you think of this? I went to tractor supply earlier and the trans shifted as it should but when I came out it was raining really hard and I was it town so I put it in 3rd and as soon as it shifter to lock-up, it went crazy, locking and unlocking 2 times a second untill I hit the lock-up switch. When I got on the highway and hit 4th lock-up it did the same thing. I went to the movies and when I came out it wasnt raining and the road wasnt as wet and the trans almost acted normal again except the occasional glitch.:think: I have babied this truck like crazy but I get nothing in return so now in driving it like a teenager pissed off at the world!:ahhh:

Link to comment
Share on other sites

×
×
  • Create New...