Jump to content
  • Welcome To Mopar1973Man.Com

    We can see you lurking about Mopar1973Man.Com reading articles and reading other member's posts. Are you trying to solve a problem with your Dodge / Ram Turbo Diesel Cummins? We have lots of helpful members and staff on the Mopar1973Man.Com and are willing to give guidance on how to fix or improve your truck. You know when you see good valued information here on Mopar1973Man.Com. We are not corporate owned like many of the other websites out there. Like Cummins Forum (VerticalScope Inc.). Mopar1973Man.Com is entirely privately owned and operated since 2004. Your subscription funds goes towards server maintenance and software maintenance. We happen to be one of the most friendliest and helpful websites for Cummins Owners in the world. Come join us and register and then pick a subscription plan

     

Recommended Posts

Truck revs up on its own only when under 1000 rpms. When at a stop sign or light it revs from about 800-850 but I think I’ve seen it spike as high as 1000. Code reader shows no codes but key trick shows apps voltage too high. Not sure if it’s the apps though because it’s a timbo and it’s worked great for a few months. And scanner shows throttle at 0% when it revs up. 

Link to post
Share on other sites

I’ll check. It usually fluctuates between 7-12% but I haven’t checked in a couple weeks. I noticed it didn’t do it on quick 15 min drive to the parts store about an hour ago. It first happened about a week ago, I revved it a few times to get the attention of a car in front of me that was stopped at a green light since my horn doesn’t work.  After I stopped it started revving up to 900 then 100 a few times. Then happened at every stop the next 20 min. After driving 4+ hours on the highway back to Tucson it was fine. Didn’t rev at anymore stops in town. It’s done it a few times since and every time it does it, seems to be after I tap the throttle a couple times while stopped.

Link to post
Share on other sites
  • Administrator
16 hours ago, ColoradoColt said:

Just checked load% at idle and it bounces between 3.5 and 5%.

Just checked again after driving 10 miles, now it’s  0.00-1.2.

 

Diesel Auto Power.

 

7 x 0.010 Injector popped at 320 bar. New idle was about 13 to 14%. Now its about 7 to 9% engine load without A/C. I'm coming to the end on my injectors too maybe another year and be washed out. These will barely make 3 years and 120k miles. 

  • Sad 1
Link to post
Share on other sites
×
×
  • Create New...