Jump to content

Archived

This topic is now archived and is closed to further replies.

BobCat

A laugh on me...

Recommended Posts

So there is a yellow light on the dash, left side of steering column, low, that has been flashing when I come in the gate and down the bumpy road. I'm thinking it is the airbag warning light, sure I've seen it there, worried maybe the flashing on a bumpy road is telling me the collision sensor is getting tired (truck is a '95) and maybe I'm fixin' to eat the airbag, next big jolt.This morning it was flashing more frequently, and seemed to stay on for a while during braking. The angle is bad, my height and where I sit with respect to the wheel, and there is a stalk for the adjustable steering column right in line-of-sight. So I'm drivin' and worrin' and get to an empty spot where I can take eyes off the road for a few seconds. Straight line, start braking, light comes on, I crane my head down to see, and it says: Low WashNever knew the windshield washer fluid tank had a low-level sensor. I feel like a dummy - and the light next to that one, that comes on with the ignition key for a second or so, is not Airbag, it is anti-lock brakes.Anyway, I guess you will laugh (I sure did), but the moral of the story is to look before you worry.Regards,AndrewOh - and we are at 478,900 or so - looking at half a million miles by late 2012, if we're both still runnin'

Share this post


Link to post
Share on other sites

Don't worry Andy... I've been doin' the same dang kind of stuff lately. I even believed you about the airbag light too :lmao:

Share this post


Link to post
Share on other sites

Thanks!Got glasses - bifocals even.Don't know where the "airbag" idea came from - maybe because it is a system I've never worked on, and the idea of having a propellant charge aimed at my chest makes me nervous. Propellant is what smokeless powder is... and by this time, the bag itself is probably "compromised" - (rotten and won't hold pressure) - so if it ever goes off, I'm going to get singed pretty well.OTOH I filled the washer fluid and the light stopped flashing, so the system actually worked as intended.This truck amazes me.

Share this post


Link to post
Share on other sites

You would love riding with me then. Every single light is on, even some I hotwired to come on (4wd light) :lmao: My oil pressure gauge is on the fritz and goes to 0 all the time, sometimes for a longgggggg time. People who ride with me start freaking out and I always tell them "oh it's fine, as long as it jiggles once every 10 miles it has plenty of oil" :lmao2:

Share this post


Link to post
Share on other sites



×