Jump to content

Steering column gauge pod


Recommended Posts

ordered myself up a steering column gauge pod for a trans. temp gauge. Its an autometer pod. I'm a little thrown off by it. There are no obvious ways of mounting it? It came with some sticky tape and barbed fasteners. How are these pods monted properly? BTW, I have not broke into the column to see what to expect yet. I figured someone on here ought to know?

Link to comment
Share on other sites

from the sounds of it , you have to drill holes and rivet with the barbed connectors or just use the sticky tape? No instructions?

It has instructions. Just sucks in a way that it was not OEM.

I ended up cutting a piece out of my factory column cover so the auto meter cover would fit tight over it. I cant remember if I used double sided tape or if its just setting up there but it does not move or anything.

What do you mean cut a piece?

Mine just sits over top of the steering column and I drilled little holes in it to push those little barbed rivets into. Worked great.

Do the barbs push into anyting or is it just a means to add friction?
Link to comment
Share on other sites

The plastic retainers (can't remember the correct name) are barbed and press into the hole but won't pull back out easily. It is important to drill the correct size hole and not let the bit wallow out the plastic. It turns out alright but not "prefect" by any means. I was disappointed that the pod mount didn't replace the existing steering column top cover, but rather just sat on top of it. Cheapo--- Hope this helps

  • Like 1
Link to comment
Share on other sites

The plastic retainers (can't remember the correct name) are barbed and press into the hole but won't pull back out easily. It is important to drill the correct size hole and not let the bit wallow out the plastic. It turns out alright but not "prefect" by any means. I was disappointed that the pod mount didn't replace the existing steering column top cover, but rather just sat on top of it. Cheapo--- Hope this helps

...that burst my bubble a little bit. I thought it replaced the OEM, not go over the top of it. :doh:
Link to comment
Share on other sites

Alright guys, trying to install the gauge and pod, etc. Looking at the lines, I'm not sure of which line to connect the sensor to. Which is the outlet line from the transmission? Seems I have only 2 choices: 1. Line that goes to front cooler. 2. Line that goes to coolant exchanger. :think:

Link to comment
Share on other sites

I ran a column pod for a while, the gauge location is nice but it blocks too much of the regular dash (like the 4wd light) so I removed it.

If you moved it where did you mount it at in the truck? I have the a-pillar mount with 3 and had no place to mount the rail pressure gauge, so on top of the column it went. 2003 Ram Cummins NV5600 with gauges and a Smarty! Not much more. Sent from my iPhone using Tapatalk
Link to comment
Share on other sites

×
×
  • Create New...