Jump to content

Recommended Posts

Double check the ECT connection make sure both connections have locked together. If the ECT lead is OPEN you get the pegged coolant gauge.

Share this post


Link to post
Share on other sites
4 minutes ago, Mopar1973Man said:

Double check the ECT connection make sure both connections have locked together. If the ECT lead is OPEN you get the pegged coolant gauge.

I'll check that now. Does it matter if the switch is plugged into the harness? It currently is not plugged in. However high idle has not been flashed on yet. 

Share this post


Link to post
Share on other sites

If the ECT line is open it does matter... It must connect to the sensor one way or another. It doesn't matter if the flash is done or not. You can still use the OFF and MPG mode. The 3 CYL and 6 CYL just will not respond. Again make sure all connection are hooked up the truck will be fine and drive without codes.

Share this post


Link to post
Share on other sites

Ive been following these high idle  threads

 

Can you explain what happens in the MPG mode and is it used for getting better fuel mileage or something else?

Edited by GSP7

Share this post


Link to post
Share on other sites

Must a diablo power puck be unplugged prior to plugging in the smarty? 

 

If yes, it has two locations it plugs in. Do I just unplug both of those and not plug anything into those locations? 

Edited by Red Rambler

Share this post


Link to post
Share on other sites

I have completed my install and tested the high idle. All works as it should. Very easy to install and plenty of loom for the location I installed my switch at. I did not unplug the power puck. Also my check engine light is no longer on, it must have been due to not having the switch plugged in. 

IMG_0627.JPG.4dd5542ef05c86f270df2d454d037c7a.JPG

 

Edited by Red Rambler

Share this post


Link to post
Share on other sites

Question: After starting a vehicle in 3cyl high idle mode, how long does it take for the various stages to kick in?

Share this post


Link to post
Share on other sites
48 minutes ago, kzimmer said:

Question: After starting a vehicle in 3cyl high idle mode, how long does it take for the various stages to kick in?

Mine was idled up to 1200 RPM's roughly two minutes after starting and running in 3cyl mode. 

Share this post


Link to post
Share on other sites

Can you explain what happens in the MPG mode and is it used for getting better fuel mileage or something else?

Share this post


Link to post
Share on other sites
40 minutes ago, GSP7 said:

Can you explain what happens in the MPG mode and is it used for getting better fuel mileage or something else?

 

Simply... It fools the IAT to a higher temperature to imitate summer conditions which retards the timing. Excessive timing tends to pull the MPG's down. 

Share this post


Link to post
Share on other sites
1 hour ago, Red Rambler said:

Mine was idled up to 1200 RPM's roughly two minutes after starting and running in 3cyl mode. 

 

Then why the hell haven't I bought one of these yet? Lol.

  • Haha 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×