Jump to content
  • Welcome To Mopar1973Man.Com

    We can see that your guest and been lurking about. When you register on the Mopar1973Man.Com site you'll be able to interact with all the other members. This is the most friendliest Cummins forum you'll ever join. Take the time right now and  REGISTER  on the Mopar1973Man.Com this will open up many more options and functions on the website. Everyone is very friendly and helpful just ask questions and everyone will help you out the best they can. 

Recommended Posts

Not the first time this had happened, I’ve been out camping where the temps were in the low 20’s at night, furnace went all night long and worked flawlessly. and kept the water from freezing in the underbelly, Got home and decided to let the furnace run and winterize the pipes later. Well it made a horrible Noise and vibration at start up and I thought it was going to fly apart. I started to tear into it and try to isolate the issue, I pulled the squirrel cage cover off and their lies the problem.

 

 

38B850A9-36D6-4BB0-BBA0-FD0300DB1F0F.jpeg

  • Sad 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...