Jump to content
  • Welcome To Mopar1973Man.Com

    We can see you lurking about Mopar1973Man.Com reading articles and reading other member's posts. Are you trying to solve a problem with your Dodge / Ram Turbo Diesel Cummins? We have lots of helpful members and staff on the Mopar1973Man.Com and are willing to give guidance on how to fix or improve your truck. You know when you see good valued information here on Mopar1973Man.Com. We are not corporate owned like many of the other websites out there. Like Cummins Forum (VerticalScope Inc.). Mopar1973Man.Com is entirely privately owned and operated since 2004. Your subscription funds goes towards server maintenance and software maintenance. We happen to be one of the most friendliest and helpful websites for Cummins Owners in the world. Come join us and register and then pick a subscription plan

     

Recommended Posts

Had a couple frosty mornings out here the past 2 days and noticed the wipers started real slow. Today I leave in a drizzle and no wipers at all. So I figure the wiper motor is shot. Have open it up and make sure the linkage is not bound up and if not it is new wiper motor time. Anything else I should look at that anyone knows?

 

Link to post
Share on other sites
  • Board Of Directors

Clean up the linkage and add a little lube/grease to the moving parts.  With the cowling off, now is a good time to install a screen or filter over the fresh air openings for the HVAC system.  I have my cowling off now and before I put it back on I'm thinking about installing window screening over the openings with  some type of glue to hold it in place.  I've had good luck with Amazing Goop Automotive adhesive.

  • Like 2
Link to post
Share on other sites
  • Board Of Directors
2 hours ago, Tractorman said:

I Installed these cabin filters from Geno's after I replaced my heater core about 75,000 miles ago.  I wished I would have done it when the truck was new.

 

- John

Yes, I need filters too...... on my 01 the evaporator was almost half clogged with debri and the blower cage/ fan was full of leaves at 190,000. 

 

Anyone know if there is a fix for wipers that sometimes stop in the wrong place. They always correct themselves eventually, but wondering if there is an adjustment somewhere. T.I.A.

Edited by JAG1
Link to post
Share on other sites

I was also thinking of some kind of screen on the underside of the cowl rather than the filters from Geno's. I like their setup but I guess I'm being cheap. I also need to replace a couple of the funny retaining screws that hold the cowl down and the rubber strip that runs across it. That is missing.

Link to post
Share on other sites
  • Board Of Directors
1 hour ago, Doubletrouble said:

I also need to replace a couple of the funny retaining screws that hold the cowl down and the rubber strip that runs across it. That is missing.

I just pulled those parts of a "98 truck at a Pick Your Part yard this week.

Link to post
Share on other sites

I pulled the motor today. Cleaned the connectors and was able to get work on one wiper. Just doesn't have the umph left to run both. Plus it wont park anymore, on off only. Nobody has a motor instock so i got to order one. No rain in the forecast this week so maybe it will get before the rain returns.

Link to post
Share on other sites
On 12/5/2020 at 7:27 AM, Doubletrouble said:

I was also thinking of some kind of screen on the underside of the cowl rather than the filters from Geno's. I like their setup but I guess I'm being cheap. 

I put window screen on mine with hot glue gun, seems to work.20180812_113729.jpg.03366ddf2031fbf66b016bf5da1f46d6.jpg

There are some smaller holes on the side that I also put some in, can't see it in the picture

Link to post
Share on other sites
  • Board Of Directors

I have my cowl off now due to my truck getting body work and new paint.  I'll try some type of filter/screening before being put back together.  

  • Like 1
Link to post
Share on other sites
  • Administrator
11 hours ago, dripley said:

Ordered one today. Should be here Thursday.

 

I've seen a lot of this lately. Check the local NAPA for simple thing like seal or gasket maybe a thermostat no stock. But now head to RockAuto sure enough they have the part in stock yet. Like my last trip to Lewiston I was trying to get injector seals for Jacob truck and nothing in stock. We tried O'Rilley's and no problem they had it. Amazing how much stock is not there. 

Link to post
Share on other sites
11 hours ago, Mopar1973Man said:

 

I've seen a lot of this lately. Check the local NAPA for simple thing like seal or gasket maybe a thermostat no stock. But now head to RockAuto sure enough they have the part in stock yet. Like my last trip to Lewiston I was trying to get injector seals for Jacob truck and nothing in stock. We tried O'Rilley's and no problem they had it. Amazing how much stock is not there. 

No one here stocked the pump. Had to order. Almost bought from AA but ordered some extra stuff to. AA had 20% off and free shipping but RA wa still 15% cheaper. Funny thing is the Car Quest part showed the same pump with the Cardone sticker on it. Alll in all I saved 20 % or more from RA. Though with AA if the part fails they will just give another. Got weigh out where you get off better I guess. Who knows the best decision on that doo doo.

On top of that I got my tracking info on the parts. RA said usps on the shipping method I chose and the tracking says fed ex ground to be delivere by Wednesday this week. Not bad for cheap shipping and ordering on Sunday evening.

Link to post
Share on other sites
  • Board Of Directors
On 12/6/2020 at 7:26 PM, IBMobile said:

I have my cowl off now due to my truck getting body work and new paint.  I'll try some type of filter/screening before being put back together.  

We won't be able to breath till you post a picture of the work when done. And Dripley won't be able to work on the Chick-Fil-A's. much.

Edited by JAG1
  • Haha 1
Link to post
Share on other sites

My parts got here Wednesday, not bad for ordering on Sunday night and economy shipping. Pretty happy that.  But got up for work Wednesday morning at 5:30 and while standing in front of the bath tub buck naked,  there is no hot water. Get your mind around that picture. Water heaters craps the bed. So while working at the CFA I call my son and ask him what he is doing this afternoon. He tells me he is knocking early to relax. Bad day for me to call but he hears my situation and goes and picks up the heater and gets to the house and helps install it. Damn good man he is.

The wife got a plumber to come over and check it out. He tells me over the phone that it will cost 1200 bucks to replace the heater. $540 for the heater cause its a low boy and the rest labor since its in a crawl space. I aint going for that. So 400 bucks for the heater, 30 bucks for the 5th of Crown Royal and 3 hours of fun i stalling it and we have hot water again.

 

My god I think I have hijacked my own thread.:sofa:

 

Anyway i was thinking of screening tha back side of the cowl. Kind of a different take on @Dieselfuture screening the openings under the cowl.

  • Like 1
Link to post
Share on other sites

I had to go to work today and after answering questions, reading the news, eating my breakfast and it warmed up nicely I went after the wipers. Before ordering parts I did a little testing and got to thinking it just might be the multifunction switch. I was convinced enough that I ordered both. Sho nuff it was the switch. But I swapped both so maybe I want have to go in there for that again. So I now have working wipers and a new washer pump, the old one was a bit tired. I can now wash the roof of my truck again while sitting still. 

But in my wisdom I forgot the screen for under the cowl. So I am still screen less.

 

Thanks to all and special thanks to @IBMobilefor the graphics. Whew!!!

Link to post
Share on other sites
×
×
  • Create New...